aboutsummaryrefslogtreecommitdiff
path: root/devel/kscope/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/kscope/Makefile')
-rw-r--r--devel/kscope/Makefile7
1 files changed, 3 insertions, 4 deletions
diff --git a/devel/kscope/Makefile b/devel/kscope/Makefile
index 7c4e947d51a4..e78b6b0a74e6 100644
--- a/devel/kscope/Makefile
+++ b/devel/kscope/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= kscope
-PORTVERSION= 1.2.0
-PORTREVISION= 1
+PORTVERSION= 1.3.3
CATEGORIES= devel kde
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR=${PORTNAME}/
@@ -15,6 +14,7 @@ MASTER_SITE_SUBDIR=${PORTNAME}/
MAINTAINER= frank@exit.com
COMMENT= KDE front-end to Cscope
+BUILD_DEPENDS+= dot:${PORTSDIR}/graphics/graphviz
LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg
RUN_DEPENDS= exctags:${PORTSDIR}/devel/ctags \
cscope:${PORTSDIR}/devel/cscope
@@ -24,10 +24,9 @@ DOCSDIR= ${PREFIX}/share/doc/HTML/en/${PORTNAME}
USE_KDEBASE_VER=3
USE_AUTOTOOLS= libtool:15
USE_GMAKE= yes
-USE_REINPLACE= yes
MAKE_ENV= EXTRA_LIBRARIES="-L${LOCALBASE}/lib"
-CONFIGURE_ENV= CXXFLAGS="${PTHREAD_CFLAGS}"
+CONFIGURE_ENV= CXXFLAGS="${PTHREAD_CFLAGS}" LDFLAGS="${PTHREAD_LIBS}"
CONFIGURE_ARGS+=--with-extra-includes=${LOCALBASE}/include \
--with-extra-libs=${LOCALBASE}/lib