aboutsummaryrefslogtreecommitdiff
path: root/devel/lbpp
diff options
context:
space:
mode:
Diffstat (limited to 'devel/lbpp')
-rw-r--r--devel/lbpp/Makefile32
-rw-r--r--devel/lbpp/distinfo1
-rw-r--r--devel/lbpp/pkg-comment1
-rw-r--r--devel/lbpp/pkg-descr16
-rw-r--r--devel/lbpp/pkg-plist2
5 files changed, 52 insertions, 0 deletions
diff --git a/devel/lbpp/Makefile b/devel/lbpp/Makefile
new file mode 100644
index 000000000000..e37e27e102aa
--- /dev/null
+++ b/devel/lbpp/Makefile
@@ -0,0 +1,32 @@
+# ex:ts=8
+# Ports collection makefile for: lbpp
+# Date created: Jun 4, 2002
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= lbpp
+PORTVERSION= 0.0.6b
+CATEGORIES= devel
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= ports@FreeBSD.org
+
+USE_BZIP2= yes
+USE_GMAKE= yes
+USE_GNOME= yes
+
+post-patch:
+ @${GREP} -lR "malloc.h" ${WRKSRC} | ${XARGS} \
+ ${PERL} -pi -e "s/malloc.h/stdlib.h/g"
+ @${FIND} ${WRKSRC} -name "Makefile*" | ${XARGS} \
+ ${PERL} -pi -e "s,^CC,#CC,g ; s,^CFLAGS =,CFLAGS+=,g ; \
+ s,-Wall -g,,g"
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/lbpp ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/liblb/libLB.a ${PREFIX}/lib
+
+.include <bsd.port.mk>
diff --git a/devel/lbpp/distinfo b/devel/lbpp/distinfo
new file mode 100644
index 000000000000..7c2fbb48f8cc
--- /dev/null
+++ b/devel/lbpp/distinfo
@@ -0,0 +1 @@
+MD5 (lbpp-0.0.6b.tar.bz2) = 610cd469f932d1afec519b3e2b4a8fdc
diff --git a/devel/lbpp/pkg-comment b/devel/lbpp/pkg-comment
new file mode 100644
index 000000000000..995839412f26
--- /dev/null
+++ b/devel/lbpp/pkg-comment
@@ -0,0 +1 @@
+A front end to GCC from Liberty Basic source code
diff --git a/devel/lbpp/pkg-descr b/devel/lbpp/pkg-descr
new file mode 100644
index 000000000000..73c7dbe50f0d
--- /dev/null
+++ b/devel/lbpp/pkg-descr
@@ -0,0 +1,16 @@
+LBPP is a front end to the GNU Common Compiler (GCC) that produces C
+source code from Liberty Basic source code. This code then is fed to
+GCC to produce an executable. It is similiar to C++ compilers that
+produce C code that then is compiled. It can be thought of either as
+a GCC extension or a C translator. The architecture of LBPP was
+designed to allow statements to be added dynamically without requiring
+a recompile of the source. It accomplishes this by defining a
+standard interface between C and Liberty Basic that allows C functions
+to access all of the internal data of a Liberty Basic program. The
+fact that all of the functionality of is based in a C library, porting
+LBPP to a new platform requires only porting the library to the native
+GUI system along with necessary modifications to allow the code to
+compile. The translator should be ANSI C so porting should not be an
+issue.
+
+WWW: http://lbpp.sourceforge.net/
diff --git a/devel/lbpp/pkg-plist b/devel/lbpp/pkg-plist
new file mode 100644
index 000000000000..d0e1e7787170
--- /dev/null
+++ b/devel/lbpp/pkg-plist
@@ -0,0 +1,2 @@
+bin/lbpp
+lib/libLB.a