aboutsummaryrefslogtreecommitdiff
path: root/devel/leiningen/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/leiningen/Makefile')
-rw-r--r--devel/leiningen/Makefile8
1 files changed, 3 insertions, 5 deletions
diff --git a/devel/leiningen/Makefile b/devel/leiningen/Makefile
index 0eccd1f2c75e..4522240a4b53 100644
--- a/devel/leiningen/Makefile
+++ b/devel/leiningen/Makefile
@@ -3,11 +3,11 @@
PORTNAME= leiningen
PORTVERSION= 2.5.1
CATEGORIES= devel lisp java
-MASTER_SITES= GITHUB_LEGACY:source1 \
+MASTER_SITES= GH:source1 \
https://github.com/technomancy/leiningen/releases/download/${PORTVERSION}/:source2
-DISTFILES= leiningen-${PORTVERSION}.tar.gz:source1 \
+DISTFILES= ${DISTNAME}.tar.gz:source1 \
leiningen-${PORTVERSION}-standalone.zip:source2
-EXTRACT_ONLY= leiningen-${PORTVERSION}.tar.gz
+EXTRACT_ONLY= ${DISTNAME}.tar.gz
MAINTAINER= rpaulo@FreeBSD.org
COMMENT= Automate Clojure projects
@@ -16,8 +16,6 @@ LICENSE= EPL
USE_GITHUB= yes
GH_ACCOUNT= technomancy
-GH_TAGNAME= ${PORTVERSION}
-GH_COMMIT= 7228d5a
USE_JAVA= yes
JAVA_VERSION= 1.6+