aboutsummaryrefslogtreecommitdiff
path: root/devel/libbonobo/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/libbonobo/Makefile')
-rw-r--r--devel/libbonobo/Makefile10
1 files changed, 8 insertions, 2 deletions
diff --git a/devel/libbonobo/Makefile b/devel/libbonobo/Makefile
index c45bc6670046..05e39dabd6bf 100644
--- a/devel/libbonobo/Makefile
+++ b/devel/libbonobo/Makefile
@@ -8,7 +8,6 @@
PORTNAME= libbonobo
PORTVERSION= 2.14.0
-PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/${PORTNAME}/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}
@@ -18,13 +17,18 @@ MAINTAINER= gnome@FreeBSD.org
COMMENT= A component and compound document system for GNOME2
USE_BZIP2= yes
+
+.if !defined(REFERENCE_PORT)
+
+PORTREVISION= 2
+
USE_GMAKE= yes
USE_BISON= yes
USE_GETTEXT= yes
INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
USE_PERL5= yes
-USE_GNOME= gnomehack intlhack libxml2 orbit2
+USE_GNOME= gnomehack intlhack libxml2 orbit2 referencehack
CONFIGURE_ARGS= --with-html-dir=${PREFIX}/share/doc \
--disable-gtk-doc
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
@@ -34,3 +38,5 @@ MAKE_ENV= gnomelocaledir=${PREFIX}/share/locale
MAN1= bonobo-activation-server.1
.include <bsd.port.mk>
+
+.endif