aboutsummaryrefslogtreecommitdiff
path: root/devel/libconfuse/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/libconfuse/Makefile')
-rw-r--r--devel/libconfuse/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/devel/libconfuse/Makefile b/devel/libconfuse/Makefile
new file mode 100644
index 000000000000..2e675ef86670
--- /dev/null
+++ b/devel/libconfuse/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: libconfuse
+# Date created: 18 September 2004
+# Whom: Juraj Lutter <otis@sk.freebsd.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libconfuse
+PORTVERSION= 2.4
+CATEGORIES= devel
+MASTER_SITES= ${MASTER_SITE_SAVANNAH} \
+ ftp://ftp.wilbury.sk/pub/FreeBSD/local/distfiles/
+MASTER_SITE_SUBDIR= confuse
+DISTNAME= confuse-${PORTVERSION}
+
+MAINTAINER= otis@freebsd.sk
+COMMENT= Configuration file parsing library
+
+.if defined(WITH_CHECK)
+LIB_DEPENDS+= ${LOCALBASE}/lib/libcheck.a:${PORTSDIR}/devel/libcheck
+.endif
+
+USE_ICONV= yes
+USE_LIBTOOL_VER= 15
+CONFIGURE_ARGS+= --disable-nls
+CFLAGS+= -I${WRKSRC}/src
+.if defined(WITH_CHECK)
+CONFIGURE_ARGS+= --with-check=${LOCALBASE}
+CFLAGS+= -I${LOCALBASE}/include
+.endif
+
+.include <bsd.port.mk>