aboutsummaryrefslogtreecommitdiff
path: root/devel/libdsp
diff options
context:
space:
mode:
Diffstat (limited to 'devel/libdsp')
-rw-r--r--devel/libdsp/Makefile9
1 files changed, 6 insertions, 3 deletions
diff --git a/devel/libdsp/Makefile b/devel/libdsp/Makefile
index de530a374752..feed020d00c6 100644
--- a/devel/libdsp/Makefile
+++ b/devel/libdsp/Makefile
@@ -16,11 +16,10 @@ DISTNAME= ${PORTNAME}-src-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= C++ class library of common digital signal processing functions
-# dont use "USE_LIBTOOL=yes" because there's no configure script
-BUILD_DEPENDS= libtool:${PORTSDIR}/devel/libtool
-
WRKSRC= ${WRKDIR}/libdsp-src/${PORTNAME:S/dsp/DSP/}-${PORTVERSION}
+USE_LIBTOOL= yes
+LIBTOOLFILES= # none
USE_GMAKE= yes
MAKE_ENV= CXX="${CXX}" CXXFLAGS="${CXXFLAGS}" MKDIR="${MKDIR}" \
INLINE_VER="${INLINE_VER}"
@@ -29,6 +28,10 @@ INSTALLS_SHLIB= yes
INLINE_VER= 1.2.5
+# There's no configure script, but we need libtool to build
+do-configure:
+ @${DO_NADA}
+
.include <bsd.port.pre.mk>
.if ${ARCH} == "i386"