aboutsummaryrefslogtreecommitdiff
path: root/devel/libftdi/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/libftdi/Makefile')
-rw-r--r--devel/libftdi/Makefile18
1 files changed, 15 insertions, 3 deletions
diff --git a/devel/libftdi/Makefile b/devel/libftdi/Makefile
index 3ce3cd6edbcb..76f9b4d0fe3f 100644
--- a/devel/libftdi/Makefile
+++ b/devel/libftdi/Makefile
@@ -13,8 +13,6 @@ MASTER_SITES= http://www.intra2net.com/de/produkte/opensource/ftdi/TGZ/
MAINTAINER= o.davydenko@gmail.com
COMMENT= A library (using libusb) to talk to FTDI chips
-LIB_DEPENDS= usb-0.1:${PORTSDIR}/devel/libusb
-
USE_AUTOTOOLS= libtool:15
GNU_CONFIGURE= yes
CONFIGURE_ENV= CFLAGS="${CFLAGS} -I${LOCALBASE}/include"
@@ -23,10 +21,24 @@ USE_GNOME= pkgconfig gnomehack
PORTDOCS= COPYING.LIB ChangeLog README
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 800069
+LIB_DEPENDS+= usb-0.1:${PORTSDIR}/devel/libusb
+.else
+EXTRA_PATCHES= ${FILESDIR}/extra-patch-configure.in
+USE_AUTOTOOLS+= autoconf:262
+.endif
+
+post-patch:
+.if ${OSVERSION} >= 800069
+ ${RM} -f ${WRKSRC}/configure
+.endif
+
post-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${DOCSDIR}
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>