aboutsummaryrefslogtreecommitdiff
path: root/devel/libgtop2/files
diff options
context:
space:
mode:
Diffstat (limited to 'devel/libgtop2/files')
-rw-r--r--devel/libgtop2/files/patch-ab17
-rw-r--r--devel/libgtop2/files/patch-ac26
-rw-r--r--devel/libgtop2/files/patch-ltmain.sh42
3 files changed, 74 insertions, 11 deletions
diff --git a/devel/libgtop2/files/patch-ab b/devel/libgtop2/files/patch-ab
index c1b39624b2fe..6c8bb313de70 100644
--- a/devel/libgtop2/files/patch-ab
+++ b/devel/libgtop2/files/patch-ab
@@ -1,6 +1,9 @@
---- Makefile.in.orig Tue Oct 19 06:04:23 1999
-+++ Makefile.in Tue Oct 26 11:42:07 1999
-@@ -187,7 +187,7 @@
+
+$FreeBSD$
+
+--- Makefile.in.orig Mon Jan 28 16:22:04 2002
++++ Makefile.in Mon Jan 28 16:23:07 2002
+@@ -193,7 +193,7 @@
EXTRA_DIST = autogen.sh libgtop.spec.in copyright.txt libgtopConf.sh.in LIBGTOP-VERSION features.def libgtop-config.in RELNOTES-0.25 RELNOTES-1.0 RELNOTES-1.0.x libgtop-sysdeps.m4 README libgtop-mirror.sh
@@ -9,16 +12,16 @@
confexec_DATA = $(top_builddir)/libgtopConf.sh $(top_builddir)/libgtop-features.def
-@@ -558,7 +558,7 @@
- $(top_srcdir)/aclocal.m4: libgtop-sysdeps.m4
+@@ -565,7 +565,7 @@
+ $(top_srcdir)/aclocal.m4: libgtop-sysdeps.m4 LIBGTOP-VERSION
libgtopConf.sh: libgtopConf.sh.in Makefile
- sed -e 's#\@LIBGTOP_LIBDIR\@#$(libdir)#g' \
+ sed -e 's#\@LIBGTOP_LIBDIR\@#$(confexecdir)#g' \
- -e 's#\@LIBGTOP_INCLUDEDIR\@#$(includedir)#g' \
+ -e 's#\@LIBGTOP_INCLUDEDIR\@#$(includedir)/libgtop-1.0#g' \
-e 's#\@LIBGTOP_DATADIR\@#$(datadir)#g' \
-e 's#\@LIBGTOP_EXTRA_LIBS\@#$(LIBGTOP_EXTRA_LIBS)#g' \
-@@ -587,7 +587,7 @@
+@@ -594,7 +594,7 @@
&& mv libgtopConf.tmp libgtopConf.sh
libgtop-config: libgtop-config.in Makefile
diff --git a/devel/libgtop2/files/patch-ac b/devel/libgtop2/files/patch-ac
index f2e96066aab2..586694a034dd 100644
--- a/devel/libgtop2/files/patch-ac
+++ b/devel/libgtop2/files/patch-ac
@@ -1,6 +1,24 @@
---- configure.orig Tue Oct 19 04:16:30 1999
-+++ configure Tue Oct 26 11:46:41 1999
-@@ -971,9 +971,9 @@
+
+$FreeBSD$
+
+--- configure.orig Mon Jan 28 16:26:32 2002
++++ configure Mon Jan 28 16:34:25 2002
+@@ -1260,10 +1260,10 @@
+
+ # The aliases save the names the user supplied, while $host etc.
+ # will get canonicalized.
+-test -n "$target_alias" &&
+- test "$program_prefix$program_suffix$program_transform_name" = \
+- NONENONEs,x,x, &&
+- program_prefix=${target_alias}-
++#test -n "$target_alias" &&
++# test "$program_prefix$program_suffix$program_transform_name" = \
++# NONENONEs,x,x, &&
++# program_prefix=${target_alias}-
+
+ # Extract the first word of "dc", so it can be a program name with args.
+ set dummy dc; ac_word=$2
+@@ -1580,9 +1580,9 @@
# libtool versioning
LT_RELEASE=$LIBGTOP_MAJOR_VERSION.$LIBGTOP_MINOR_VERSION
@@ -12,4 +30,4 @@
+LT_AGE=0
LT_VERSION_INFO='-version-info ${LT_CURRENT}:${LT_REVISION}:${LT_AGE}'
-
+ if test x = y; then
diff --git a/devel/libgtop2/files/patch-ltmain.sh b/devel/libgtop2/files/patch-ltmain.sh
new file mode 100644
index 000000000000..3284d88e43f0
--- /dev/null
+++ b/devel/libgtop2/files/patch-ltmain.sh
@@ -0,0 +1,42 @@
+
+$FreeBSD$
+
+--- ltmain.sh.orig Sun Jan 20 16:11:07 2002
++++ ltmain.sh Thu Jan 24 17:07:06 2002
+@@ -1058,8 +1058,13 @@
+ continue
+ ;;
+
++ -pthread)
++ compiler_flags="$compiler_flags -pthread"
++ ;;
++
+ -module)
+ module=yes
++ build_old_libs=no
+ continue
+ ;;
+
+@@ -2442,6 +2447,9 @@
+ *-*-openbsd*)
+ # Do not include libc due to us having libc/libc_r.
+ ;;
++ *-*-freebsd*)
++ # FreeBSD doesn't need this...
++ ;;
+ *)
+ # Add libc to deplibs on all other systems if necessary.
+ if test $build_libtool_need_lc = "yes"; then
+@@ -4208,10 +4216,12 @@
+ fi
+
+ # Install the pseudo-library for information purposes.
++ if /usr/bin/false; then
+ name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
+ instname="$dir/$name"i
+ $show "$install_prog $instname $destdir/$name"
+ $run eval "$install_prog $instname $destdir/$name" || exit $?
++ fi
+
+ # Maybe install the static library, too.
+ test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"