aboutsummaryrefslogtreecommitdiff
path: root/devel/libhtp/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/libhtp/Makefile')
-rw-r--r--devel/libhtp/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/devel/libhtp/Makefile b/devel/libhtp/Makefile
index 98075c70a9bb..f96ae46cce11 100644
--- a/devel/libhtp/Makefile
+++ b/devel/libhtp/Makefile
@@ -1,17 +1,18 @@
# $FreeBSD$
PORTNAME= libhtp
-PORTVERSION= 0.5.12
+PORTVERSION= 0.5.15
CATEGORIES= devel
MAINTAINER= koobs@FreeBSD.org
COMMENT= Security-aware parser for the HTTP protocol
LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
USE_GITHUB= yes
GH_ACCOUNT= ironbee
-GH_COMMIT= a85cb55
+GH_COMMIT= 440da09
USES= libtool pkgconfig pathfix iconv
USE_AUTOTOOLS= libtoolize automake aclocal autoheader
@@ -19,12 +20,15 @@ USE_LDCONFIG= yes
AUTOMAKE_ARGS= --add-missing
CONFIGURE_ARGS= ${ICONV_CONFIGURE_ARG}
+MAKE_ARGS= LIBS="-lz ${ICONV_LIB}"
PATHFIX_MAKEFILEIN= Makefile.am
INSTALL_TARGET= install-strip
CONFLICTS_INSTALL= libhtp-suricata-*
+PLIST_SUB+= PORTVERSION="${PORTVERSION}"
+
regression-test: build
@cd ${WRKSRC} && ${MAKE} check