aboutsummaryrefslogtreecommitdiff
path: root/devel/liboobs/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/liboobs/Makefile')
-rw-r--r--devel/liboobs/Makefile12
1 files changed, 7 insertions, 5 deletions
diff --git a/devel/liboobs/Makefile b/devel/liboobs/Makefile
index b9f987d7cd72..836643c0a7cb 100644
--- a/devel/liboobs/Makefile
+++ b/devel/liboobs/Makefile
@@ -3,20 +3,21 @@
# Whom: Michael Johnson <ahze@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports/devel/liboobs/Makefile,v 1.23 2007/09/16 16:45:35 ahze Exp $
+# $MCom: ports/devel/liboobs/Makefile,v 1.35 2008/03/09 18:52:59 mezz Exp $
#
PORTNAME= liboobs
-PORTVERSION= 2.20.0
+PORTVERSION= 2.22.0
CATEGORIES= devel gnome
-MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= sources/${PORTNAME}/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}
+MASTER_SITES= GNOME
+DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
COMMENT= Wrapping library to the System Tools Backends
BUILD_DEPENDS= ${LOCALBASE}/etc/dbus-1/system.d/system-tools-backends.conf:${PORTSDIR}/sysutils/system-tools-backends
-LIB_DEPENDS= dbus-glib-1.2:${PORTSDIR}/devel/dbus-glib
+LIB_DEPENDS= dbus-glib-1.2:${PORTSDIR}/devel/dbus-glib \
+ hal.1:${PORTSDIR}/sysutils/hal
RUN_DEPENDS= ${LOCALBASE}/etc/dbus-1/system.d/system-tools-backends.conf:${PORTSDIR}/sysutils/system-tools-backends
USE_BZIP2= yes
@@ -24,5 +25,6 @@ GNU_CONFIGURE= yes
USE_GNOME= gnomehack glib20
USE_LDCONFIG= yes
CONFIGURE_ARGS= --with-html-dir=${PREFIX}/share/doc
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include"
.include <bsd.port.mk>