aboutsummaryrefslogtreecommitdiff
path: root/devel/liborcus/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/liborcus/Makefile')
-rw-r--r--devel/liborcus/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/devel/liborcus/Makefile b/devel/liborcus/Makefile
index 5b89175ddded..5ff0e2f25509 100644
--- a/devel/liborcus/Makefile
+++ b/devel/liborcus/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= liborcus
-PORTVERSION= 0.9.2
+PORTVERSION= 0.11.2
CATEGORIES= devel misc
MASTER_SITES= http://kohei.us/files/orcus/src/
@@ -10,7 +10,7 @@ COMMENT= Standalone file import filter library for spreadsheet documents
LICENSE= MIT
-BUILD_DEPENDS= ${LOCALBASE}/include/mdds/global.hpp:devel/mdds0
+BUILD_DEPENDS= ${LOCALBASE}/include/mdds-1.2/mdds/global.hpp:devel/mdds
LIB_DEPENDS= libboost_system.so:devel/boost-libs
GNU_CONFIGURE= yes
@@ -20,7 +20,8 @@ INSTALL_TARGET= install-strip
CONFIGURE_ARGS= --disable-spreadsheet-model --disable-werror \
--with-boost="${LOCALBASE}" \
- --with-boost-system=boost_system
+ --with-boost-system=boost_system \
+ --disable-python
CONFIGURE_ENV= ZLIB_CFLAGS="-I/usr/include" ZLIB_LIBS="-lz"
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib