aboutsummaryrefslogtreecommitdiff
path: root/devel/liborcus07/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/liborcus07/Makefile')
-rw-r--r--devel/liborcus07/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/devel/liborcus07/Makefile b/devel/liborcus07/Makefile
new file mode 100644
index 000000000000..51c4d83f17fe
--- /dev/null
+++ b/devel/liborcus07/Makefile
@@ -0,0 +1,30 @@
+# $FreeBSD$
+
+PORTNAME= liborcus
+PORTVERSION= 0.7.0
+CATEGORIES= devel misc
+MASTER_SITES= http://kohei.us/files/orcus/src/
+PKGNAMESUFFIX= 07
+
+MAINTAINER= office@FreeBSD.org
+COMMENT= Standalone file import filter library for spreadsheet documents
+
+LICENSE= MIT
+
+BUILD_DEPENDS= ${LOCALBASE}/include/mdds/global.hpp:${PORTSDIR}/devel/mdds
+LIB_DEPENDS= libzip.so:${PORTSDIR}/archivers/libzip \
+ libboost_system.so:${PORTSDIR}/devel/boost-libs
+
+GNU_CONFIGURE= yes
+USES= gmake libtool pathfix pkgconfig tar:bzip2
+USE_LDCONFIG= yes
+INSTALL_TARGET= install-strip
+
+CONFIGURE_ARGS= --disable-spreadsheet-model --disable-werror \
+ --with-boost="${LOCALBASE}" \
+ --with-boost-system=boost_system
+CONFIGURE_ENV= ZLIB_CFLAGS="-I/usr/include" ZLIB_LIBS="-lz"
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+
+.include <bsd.port.mk>