aboutsummaryrefslogtreecommitdiff
path: root/devel/libowfat/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/libowfat/Makefile')
-rw-r--r--devel/libowfat/Makefile19
1 files changed, 8 insertions, 11 deletions
diff --git a/devel/libowfat/Makefile b/devel/libowfat/Makefile
index df11e4928992..bfd003244f8b 100644
--- a/devel/libowfat/Makefile
+++ b/devel/libowfat/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= libowfat
-PORTVERSION= 0.21
+PORTVERSION= 0.22
CATEGORIES= devel ipv6
MASTER_SITES= http://dl.fefe.de/
@@ -29,10 +29,13 @@ CFLAGS+= -O2 -fomit-frame-pointer
.include "${FILESDIR}/manpages"
-examples= examples/byte.c examples/str.c
-examplesdir= ${EXAMPLESDIR:S,^${PREFIX}/,,}
-PLIST_DIRS= ${examplesdir}
-PLIST_FILES= lib/libowfat.a ${examples:S,^examples/,${examplesdir}/,}
+include= array.h buffer.h byte.h case.h dns.h errmsg.h fmt.h \
+ havealloca.h io.h iob.h iopause.h ip4.h ip6.h mmap.h \
+ ndelay.h open.h openreadclose.h readclose.h safemult.h \
+ scan.h socket.h str.h stralloc.h tai.h taia.h textcode.h \
+ uint16.h uint32.h uint64.h
+PLIST_DIRS= include/libowfat
+PLIST_FILES= ${include:S,^,include/libowfat/,} lib/libowfat.a
.if!defined(NOPORTDOCS)
PORTDOCS= CHANGES README TODO
.endif
@@ -42,11 +45,5 @@ post-install:
${MKDIR} ${DOCSDIR}
cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}
.endif
- ${MKDIR} ${EXAMPLESDIR}
- cd ${WRKSRC} && ${INSTALL_DATA} ${examples} ${EXAMPLESDIR}
-# add installed header files to packaging list:
- @cd ${PREFIX} && \
- ${FIND} include/libowfat -type f -o -type l | ${SORT} >>${TMPPLIST}
- @${ECHO_CMD} "@dirrm include/libowfat" >>${TMPPLIST}
.include <bsd.port.post.mk>