aboutsummaryrefslogtreecommitdiff
path: root/devel/librelp
diff options
context:
space:
mode:
Diffstat (limited to 'devel/librelp')
-rw-r--r--devel/librelp/Makefile14
-rw-r--r--devel/librelp/distinfo4
-rw-r--r--devel/librelp/files/patch-src__tcp.c14
3 files changed, 26 insertions, 6 deletions
diff --git a/devel/librelp/Makefile b/devel/librelp/Makefile
index da97cdc2794a..63cce8dcce33 100644
--- a/devel/librelp/Makefile
+++ b/devel/librelp/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= librelp
-PORTVERSION= 1.2.0
+PORTVERSION= 1.2.7
CATEGORIES= devel
MASTER_SITES= http://download.rsyslog.com/librelp/
@@ -11,13 +11,14 @@ COMMENT= Reliable event logging protocol library
LIB_DEPENDS= libgnutls.so:${PORTSDIR}/security/gnutls
-USES= pathfix pkgconfig
-USE_AUTOTOOLS= libtool
+USES= libtool pathfix pkgconfig
+USE_AUTOTOOLS= automake aclocal
USE_LDCONFIG= yes
PLIST_FILES= include/${PORTNAME}.h \
- lib/${PORTNAME}.a lib/${PORTNAME}.la \
+ lib/${PORTNAME}.a \
lib/${PORTNAME}.so lib/${PORTNAME}.so.0 \
+ lib/${PORTNAME}.so.0.1.0 \
libdata/pkgconfig/relp.pc
PORT_VERBS= relp
@@ -25,5 +26,10 @@ PORT_VERBS= relp
post-patch:
@${REINPLACE_CMD} -e '/CFLAGS/s| -g||g' \
${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|libdir)/pkgconfig|prefix)/libdata/pkgconfig|' \
+ ${WRKSRC}/Makefile.am
+
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/librelp.so.0.1.0
.include <bsd.port.mk>
diff --git a/devel/librelp/distinfo b/devel/librelp/distinfo
index 6bd03e649449..a2ac48df040f 100644
--- a/devel/librelp/distinfo
+++ b/devel/librelp/distinfo
@@ -1,2 +1,2 @@
-SHA256 (librelp-1.2.0.tar.gz) = 5a8870fd2ae496be08d100ef8a65807311f11d6976ed37b8e0cd8024872c31e5
-SIZE (librelp-1.2.0.tar.gz) = 406527
+SHA256 (librelp-1.2.7.tar.gz) = 3a434a1c71772706104cfb1c93ba8e6809d257851d60de29ac2142c60c68d7d1
+SIZE (librelp-1.2.7.tar.gz) = 410896
diff --git a/devel/librelp/files/patch-src__tcp.c b/devel/librelp/files/patch-src__tcp.c
new file mode 100644
index 000000000000..5cce22227433
--- /dev/null
+++ b/devel/librelp/files/patch-src__tcp.c
@@ -0,0 +1,14 @@
+--- ./src/tcp.c.orig 2014-04-22 07:33:25.000000000 -0600
++++ ./src/tcp.c 2014-05-17 10:49:10.247327329 -0600
+@@ -62,7 +62,10 @@
+ static int called_gnutls_global_init = 0;
+ #endif
+
+-
++#include <netdb.h>
++#ifndef SOL_TCP
++#define SOL_TCP (getprotobyname("TCP")->p_proto)
++#endif
+
+ #ifdef ENABLE_TLS
+ /* forward definitions */