aboutsummaryrefslogtreecommitdiff
path: root/devel/libshhopt
diff options
context:
space:
mode:
Diffstat (limited to 'devel/libshhopt')
-rw-r--r--devel/libshhopt/files/Makefile3
-rw-r--r--devel/libshhopt/files/Makefile.lib3
2 files changed, 4 insertions, 2 deletions
diff --git a/devel/libshhopt/files/Makefile b/devel/libshhopt/files/Makefile
index 7d992264e100..0cc2ce8d365d 100644
--- a/devel/libshhopt/files/Makefile
+++ b/devel/libshhopt/files/Makefile
@@ -2,7 +2,8 @@
PREFIX = /usr/local
LIBDIR = $(PREFIX)/lib
-INCDIR = $(PREFIX)/include
+INCSDIR = $(PREFIX)/include
+INCDIR = $(INCSDIR) # for 4.x bsd.lib.mk
example:
$(CC) -o example example.c -I$(INCDIR) -L$(LIBDIR) -lshhopt
diff --git a/devel/libshhopt/files/Makefile.lib b/devel/libshhopt/files/Makefile.lib
index 37bf6c5cc6b6..e89e2a2dd3d1 100644
--- a/devel/libshhopt/files/Makefile.lib
+++ b/devel/libshhopt/files/Makefile.lib
@@ -9,7 +9,8 @@ NOPROFILE= yes
NOOBJ= yes
INCS= shhopt.h
-INCDIR= ${PREFIX}/include
+INCSDIR=${PREFIX}/include
+INCDIR= ${INCSDIR} # for 4.x bsd.lib.mk
SRCS= shhopt.c