aboutsummaryrefslogtreecommitdiff
path: root/devel/libslang2/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/libslang2/Makefile')
-rw-r--r--devel/libslang2/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/devel/libslang2/Makefile b/devel/libslang2/Makefile
index bd16700a725a..8974146b9315 100644
--- a/devel/libslang2/Makefile
+++ b/devel/libslang2/Makefile
@@ -28,10 +28,15 @@ INSTALL_TARGET= install install-elf
MAN1= slsh.1
DOCSDIR= ${PREFIX}/share/doc/slang
+OPTIONS= PCRE "Include pcre support" on \
+ PNG "Include png support" on
+
.if !defined(NOPORTDOCS)
PORTDOCS= *
.endif
+.include <bsd.port.pre.mk>
+
.if !defined(WITHOUT_PCRE)
LIB_DEPENDS+= pcre.0:${PORTSDIR}/devel/pcre
PLIST_SUB+= PCRE=""
@@ -48,8 +53,6 @@ CONFIGURE_ARGS+= --disable-png
PLIST_SUB+= PNG="@comment "
.endif
-.include <bsd.port.pre.mk>
-
post-patch:
.if defined(NOPORTDOCS)
@${REINPLACE_CMD} -e 's, install_docs,,g' ${WRKSRC}/src/Makefile.in