aboutsummaryrefslogtreecommitdiff
path: root/devel/libsoup/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/libsoup/Makefile')
-rw-r--r--devel/libsoup/Makefile20
1 files changed, 8 insertions, 12 deletions
diff --git a/devel/libsoup/Makefile b/devel/libsoup/Makefile
index 7dd00661a1d2..484eea545a01 100644
--- a/devel/libsoup/Makefile
+++ b/devel/libsoup/Makefile
@@ -6,31 +6,27 @@
#
PORTNAME= soup
-PORTVERSION= 0.5.1
+PORTVERSION= 0.7.4
CATEGORIES= devel gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= unstable/sources/soup
+DIST_SUBDIR= gnome
MAINTAINER= gnome@FreeBSD.org
-LIB_DEPENDS= popt.0:${PORTSDIR}/devel/popt \
- xml.5:${PORTSDIR}/textproc/libxml
-
-WRKSRC= ${WRKDIR}/${DISTNAME}
+LIB_DEPENDS= popt.0:${PORTSDIR}/devel/popt
+USE_BZIP2= yes
USE_GNOMENG= yes
-USE_GNOME= glib12
+USE_GNOME= gnomehack glib12 libxml
INSTALLS_SHLIB= yes
-GNU_CONFIGURE= yes
+USE_LIBTOOL= yes
CONFIGURE_ARGS= --with-html-dir=${PREFIX}/share/doc
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
-pre-patch:
- @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
+post-patch:
+ @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
- @find ${WRKSRC} -name "Makefile.in*" | xargs ${PERL} -pi -e \
- 's|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g ; \
- s|\$\(libdir\)/pkgconfig|\$\(prefix\)/libdata/pkgconfig|g'
.include <bsd.port.mk>