aboutsummaryrefslogtreecommitdiff
path: root/devel/libsoup/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/libsoup/Makefile')
-rw-r--r--devel/libsoup/Makefile21
1 files changed, 8 insertions, 13 deletions
diff --git a/devel/libsoup/Makefile b/devel/libsoup/Makefile
index 4499159db03e..5e10e68eb116 100644
--- a/devel/libsoup/Makefile
+++ b/devel/libsoup/Makefile
@@ -2,34 +2,31 @@
# $FreeBSD$
PORTNAME= libsoup
-PORTVERSION= 2.54.1
-PORTREVISION= 0
+PORTVERSION= 2.62.2
CATEGORIES= devel gnome
MASTER_SITES= GNOME
-DIST_SUBDIR= gnome2
+DIST_SUBDIR= gnome
MAINTAINER= gnome@FreeBSD.org
COMMENT= SOAP (Simple Object Access Protocol) implementation in C
+LICENSE= LGPL20
+LICENSE_FILE= ${WRKSRC}/COPYING
+
BUILD_DEPENDS= glib-networking>=2.29.18:net/glib-networking
LIB_DEPENDS= libgcrypt.so:security/libgcrypt
RUN_DEPENDS= glib-networking>=2.29.18:net/glib-networking
-USES= tar:xz
PORTSCOUT= limitw:1,even
-.if !defined(REFERENCE_PORT)
-
-USES+= gettext gmake gnome libtool pathfix pkgconfig \
- python:build sqlite:3 tar:xz
+USES= gettext gmake gnome libtool localbase pathfix \
+ pkgconfig python:3.6+,build sqlite ssl tar:xz
USE_GNOME= glib20 intlhack introspection:build \
libxml2 referencehack
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-more-warnings \
--disable-vala
-CPPFLAGS+= -I${LOCALBASE}/include
-LIBS+= -L${LOCALBASE}/lib
INSTALL_TARGET= install-strip
LIBVERSION= 1.8.0
@@ -46,7 +43,7 @@ CONFIGURE_ARGS+=--without-gnome
post-patch:
@${REINPLACE_CMD} -e 's|-Wmissing-include-dirs||g' \
${WRKSRC}/configure
- @${REINPLACE_CMD} -e 's|env python|env ${PYTHON_VERSION}|g' \
+ @${REINPLACE_CMD} -e 's|env python3|env ${PYTHON_VERSION}|g' \
${WRKSRC}/libsoup/tld-parser.py
@${REINPLACE_CMD} -e 's|DATADIRNAME=lib|DATADIRNAME=share|g' \
${WRKSRC}/configure
@@ -74,5 +71,3 @@ post-install:
.endif
.include <bsd.port.mk>
-
-.endif