aboutsummaryrefslogtreecommitdiff
path: root/devel/libtar
diff options
context:
space:
mode:
Diffstat (limited to 'devel/libtar')
-rw-r--r--devel/libtar/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/devel/libtar/Makefile b/devel/libtar/Makefile
index 7de203875e10..77fe76ab04ae 100644
--- a/devel/libtar/Makefile
+++ b/devel/libtar/Makefile
@@ -18,6 +18,7 @@ USE_GMAKE= yes
GNU_CONFIGURE= yes
INSTALLS_SHLIB= yes
CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}"
post-install:
${INSTALL_DATA} ${WRKSRC}/lib/libtar.so.0 ${PREFIX}/lib
@@ -25,4 +26,9 @@ post-install:
.include <bsd.port.pre.mk>
.include "files/manpages"
+
+.if ${ARCH}!="i386"
+CPPFLAGS+= -fPIC
+.endif
+
.include <bsd.port.post.mk>