aboutsummaryrefslogtreecommitdiff
path: root/devel/libtecla/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/libtecla/Makefile')
-rw-r--r--devel/libtecla/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/devel/libtecla/Makefile b/devel/libtecla/Makefile
new file mode 100644
index 000000000000..09596158bf39
--- /dev/null
+++ b/devel/libtecla/Makefile
@@ -0,0 +1,37 @@
+# ex:ts=8
+# New ports collection makefile for: libtecla
+# Date created: Feb 12, 2001
+# Whom: Ying-Chieh Liao <ijliao@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libtecla
+PORTVERSION= 1.2
+CATEGORIES= devel
+MASTER_SITES= http://www.astro.caltech.edu/~mcs/tecla/
+DISTNAME= ${PORTNAME}${PORTVERSION}
+
+MAINTAINER= ijliao@FreeBSD.org
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+USE_GMAKE= yes
+ALL_TARGET= libtecla.a libtecla_r.a
+
+MAN3= cfc_file_start.3 cfc_literal_escapes.3 cfc_set_check_fn.3 \
+ cpl_add_completion.3 cpl_complete_word.3 cpl_file_completions.3 \
+ cpl_last_error.3 cpl_list_completions.3 cpl_record_error.3 \
+ del_CplFileConf.3 del_ExpandFile.3 del_GetLine.3 del_PathCache.3 \
+ del_PcaPathConf.3 del_WordCompletion.3 ef_expand_file.3 \
+ ef_last_error.3 gl_change_terminal.3 gl_customize_completion.3 \
+ gl_get_line.3 libtecla.3 new_CplFileConf.3 new_ExpandFile.3 \
+ new_GetLine.3 new_PathCache.3 new_PcaPathConf.3 new_WordCompletion.3 \
+ pca_last_error.3 pca_lookup_file.3 pca_path_completions.3 \
+ pca_scan_path.3 pca_set_check_fn.3 ppc_file_start.3 \
+ ppc_literal_escapes.3
+
+post-patch:
+ @${PERL} -pi -e "s|/usr/local|${PREFIX}|g" ${WRKSRC}/Makefile
+
+.include <bsd.port.mk>