aboutsummaryrefslogtreecommitdiff
path: root/devel/libtool13
diff options
context:
space:
mode:
Diffstat (limited to 'devel/libtool13')
-rw-r--r--devel/libtool13/Makefile46
-rw-r--r--devel/libtool13/distinfo2
-rw-r--r--devel/libtool13/files/patch-aa25
-rw-r--r--devel/libtool13/files/patch-ab65
-rw-r--r--devel/libtool13/files/patch-ac25
-rw-r--r--devel/libtool13/files/patch-ad55
-rw-r--r--devel/libtool13/files/patch-ae18
-rw-r--r--devel/libtool13/files/patch-af28
-rw-r--r--devel/libtool13/files/patch-ag14
-rw-r--r--devel/libtool13/files/patch-libtoolize.in14
-rw-r--r--devel/libtool13/pkg-plist59
11 files changed, 237 insertions, 114 deletions
diff --git a/devel/libtool13/Makefile b/devel/libtool13/Makefile
index fe6e1d76b734..154c7665074d 100644
--- a/devel/libtool13/Makefile
+++ b/devel/libtool13/Makefile
@@ -6,25 +6,49 @@
#
PORTNAME= libtool
-PORTVERSION= 1.3.4
-PORTREVISION= 4
+PORTVERSION= 1.3.5
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= libtool
+DISTNAME= libtool-${PORTVERSION}
MAINTAINER= ade@FreeBSD.org
COMMENT= Generic shared library support script
-# This port has not been upgraded to 1.4 because it is used by about 30% of
-# the ports collection, and more testing is needed. If someone can supply a
-# working patch then it will be upgraded.
-
-INSTALLS_SHLIB= yes
+LATEST_LINK= libtool13
GNU_CONFIGURE= yes
-CONFIGURE_ENV= PREFIX=${PREFIX}
+CONFIGURE_ARGS= --disable-ltdl-install \
+ --program-suffix=13
+CONFIGURE_ENV= PREFIX=${PREFIX} PACKAGE=libtool13
+USE_REINPLACE= yes
+
+.if defined(USE_LIBTOOL) || defined(USE_LIBTOOL_VER)
+pre-everything:
+ @${ECHO} ===========================================================
+ @${ECHO} "You have 'USE_LIBTOOL' or 'USE_LIBTOOL_VER' variables"
+ @${ECHO} "defined either in environment or in make(1) arguments."
+ @${ECHO} "Please undefine them and try again."
+ @${ECHO} ===========================================================
+ @${FALSE}
+.endif # defined(USE_LIBTOOL) || defined(USE_LIBTOOL_VER)
+
+post-extract:
+ @${MV} -f ${WRKSRC}/libtool.m4 ${WRKSRC}/libtool13.m4
+ @${REINPLACE_CMD} -e 's|libtool.m4|libtool13.m4|g' \
+ ${WRKSRC}/Makefile.in
+ @${MV} -f ${WRKSRC}/doc/libtool.info ${WRKSRC}/doc/libtool13.info
+ @${MV} -f ${WRKSRC}/doc/libtool.texi ${WRKSRC}/doc/libtool13.texi
-.ifdef USE_LIBTOOL
-.error You have `USE_LIBTOOL' variable defined either in environment or in make(1) arguments. Please undefine and try again.
-.endif
+post-install:
+ @-${RM} -fr ${PREFIX}/libexec/libtool13
+ ${MKDIR} ${PREFIX}/libexec/libtool13
+.for i in libtool libtoolize
+ ${LN} -sf ${PREFIX}/bin/${i}13 ${PREFIX}/libexec/libtool13/${i}
+.endfor
+.for i in config.guess config.sub
+ ${MV} ${PREFIX}/share/libtool13/${i}13 ${PREFIX}/share/libtool13/${i}
+.endfor
+ ${LN} -sf ${PREFIX}/share/libtool13/ltconfig13 \
+ ${PREFIX}/share/libtool13/ltconfig
.include <bsd.port.mk>
diff --git a/devel/libtool13/distinfo b/devel/libtool13/distinfo
index c39e3aaff92d..2b891425c242 100644
--- a/devel/libtool13/distinfo
+++ b/devel/libtool13/distinfo
@@ -1 +1 @@
-MD5 (libtool-1.3.4.tar.gz) = 0c3844fedd382e5796865ca58842713e
+MD5 (libtool-1.3.5.tar.gz) = fa26a07c978ad05d1f88ed7a472daa49
diff --git a/devel/libtool13/files/patch-aa b/devel/libtool13/files/patch-aa
index 91ff871e5ae3..95c4f56b1de3 100644
--- a/devel/libtool13/files/patch-aa
+++ b/devel/libtool13/files/patch-aa
@@ -1,11 +1,28 @@
---- doc/libtool.texi.orig Tue Jun 29 15:48:12 1999
-+++ doc/libtool.texi Tue Aug 31 23:41:25 1999
-@@ -11,7 +11,7 @@
+--- doc/libtool13.texi.orig Tue Nov 2 07:36:23 1999
++++ doc/libtool13.texi Sat Dec 14 00:11:27 2002
+@@ -1,6 +1,6 @@
+ \input texinfo @c -*-texinfo-*-
+ @c %**start of header
+-@setfilename libtool.info
++@setfilename libtool13.info
+ @settitle Libtool
+ @c For double-sided printing, uncomment:
+ @c @setchapternewpage odd
+@@ -11,14 +11,14 @@
@set MAILLIST the libtool mailing list @email{libtool@@gnu.org}
@set objdir .libs
-@dircategory GNU programming tools
+@dircategory Programming & development tools
@direntry
- * Libtool: (libtool). Generic shared library support script.
+-* Libtool: (libtool). Generic shared library support script.
++* Libtool: (libtool13). Generic shared library support script.
@end direntry
+
+ @dircategory Individual utilities
+ @direntry
+-* libtoolize: (libtool)Invoking libtoolize. Adding libtool support.
++* libtoolize: (libtool13)Invoking libtoolize. Adding libtool support.
+ @end direntry
+
+ @ifinfo
diff --git a/devel/libtool13/files/patch-ab b/devel/libtool13/files/patch-ab
index f96b92eac308..18ada0907569 100644
--- a/devel/libtool13/files/patch-ab
+++ b/devel/libtool13/files/patch-ab
@@ -1,6 +1,6 @@
---- doc/Makefile.in.orig Fri Jul 2 09:24:54 1999
-+++ doc/Makefile.in Tue Aug 31 23:41:57 1999
-@@ -70,7 +70,7 @@
+--- doc/Makefile.in.orig Sat May 27 07:23:34 2000
++++ doc/Makefile.in Sat Dec 14 00:04:56 2002
+@@ -71,7 +71,7 @@
LIBTOOL = @LIBTOOL@
LIBTOOL_FLAGS = @LIBTOOL_FLAGS@
LN_S = @LN_S@
@@ -9,3 +9,62 @@
NM = @NM@
OBJDUMP = @OBJDUMP@
PACKAGE = @PACKAGE@
+@@ -81,15 +81,15 @@
+ pkgdatadir = @pkgdatadir@
+
+ AUTOMAKE_OPTIONS = gnits
+-info_TEXINFOS = libtool.texi
+-libtool_TEXINFOS = PLATFORMS
++info_TEXINFOS = libtool13.texi
++libtool13_TEXINFOS = PLATFORMS
+ mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
+ CONFIG_CLEAN_FILES =
+ TEXI2DVI = texi2dvi
+-INFO_DEPS = libtool.info
+-DVIS = libtool.dvi
+-TEXINFOS = libtool.texi
+-DIST_COMMON = $(libtool_TEXINFOS) Makefile.am Makefile.in mdate-sh \
++INFO_DEPS = libtool13.info
++DVIS = libtool13.dvi
++TEXINFOS = libtool13.texi
++DIST_COMMON = $(libtool13_TEXINFOS) Makefile.am Makefile.in mdate-sh \
+ stamp-vti texinfo.tex version.texi
+
+
+@@ -111,8 +111,8 @@
+ $(srcdir)/version.texi: stamp-vti
+ @:
+
+-$(srcdir)/stamp-vti: libtool.texi $(top_srcdir)/configure.in
+- @echo "@set UPDATED `$(SHELL) $(srcdir)/mdate-sh $(srcdir)/libtool.texi`" > vti.tmp
++$(srcdir)/stamp-vti: libtool13.texi $(top_srcdir)/configure.in
++ @echo "@set UPDATED `$(SHELL) $(srcdir)/mdate-sh $(srcdir)/libtool13.texi`" > vti.tmp
+ @echo "@set EDITION $(VERSION)" >> vti.tmp
+ @echo "@set VERSION $(VERSION)" >> vti.tmp
+ @cmp -s vti.tmp $(srcdir)/version.texi \
+@@ -131,8 +131,8 @@
+ maintainer-clean-vti:
+ -rm -f $(srcdir)/stamp-vti $(srcdir)/version.texi
+
+-libtool.info: libtool.texi version.texi $(libtool_TEXINFOS)
+-libtool.dvi: libtool.texi version.texi $(libtool_TEXINFOS)
++libtool13.info: libtool13.texi version.texi $(libtool13_TEXINFOS)
++libtool13.dvi: libtool13.texi version.texi $(libtool13_TEXINFOS)
+
+
+ DVIPS = dvips
+@@ -231,10 +231,10 @@
+ done
+
+ mostlyclean-aminfo:
+- -rm -f libtool.aux libtool.cp libtool.cps libtool.dvi libtool.fn \
+- libtool.fns libtool.ky libtool.kys libtool.ps libtool.log \
+- libtool.pg libtool.toc libtool.tp libtool.tps libtool.vr \
+- libtool.vrs libtool.op libtool.tr libtool.cv libtool.cn
++ -rm -f libtool13.aux libtool13.cp libtool13.cps libtool13.dvi libtool13.fn \
++ libtool13.fns libtool13.ky libtool13.kys libtool13.ps libtool13.log \
++ libtool13.pg libtool13.toc libtool13.tp libtool13.tps libtool13.vr \
++ libtool13.vrs libtool13.op libtool13.tr libtool13.cv libtool13.cn
+
+ clean-aminfo:
+
diff --git a/devel/libtool13/files/patch-ac b/devel/libtool13/files/patch-ac
index 3a1894e10003..b74f12d923d3 100644
--- a/devel/libtool13/files/patch-ac
+++ b/devel/libtool13/files/patch-ac
@@ -1,15 +1,12 @@
-
-$FreeBSD$
-
---- ltconfig.orig Tue Dec 7 23:50:48 1999
-+++ ltconfig Sat Jun 8 11:48:12 2002
+--- ltconfig.orig Fri Dec 13 23:36:10 2002
++++ ltconfig Fri Dec 13 23:47:30 2002
@@ -169,7 +169,7 @@
# Constants:
PROGRAM=ltconfig
PACKAGE=libtool
--VERSION=1.3.4
-+VERSION=1.3.4-freebsd-ports
- TIMESTAMP=" (1.385.2.196 1999/12/07 21:47:57)"
+-VERSION=1.3.5
++VERSION=1.3.5-freebsd-ports
+ TIMESTAMP=" (1.385.2.206 2000/05/27 11:12:27)"
ac_compile='${CC-cc} -c $CFLAGS $CPPFLAGS conftest.$ac_ext 1>&5'
ac_link='${CC-cc} -o conftest $CFLAGS $CPPFLAGS $LDFLAGS conftest.$ac_ext $LIBS 1>&5'
@@ -185,6 +185,8 @@
@@ -72,7 +69,7 @@ $FreeBSD$
echo "$ac_t"yes 1>&6
else
echo "$ac_t"no 1>&6
-@@ -1226,8 +1240,8 @@
+@@ -1232,8 +1246,8 @@
*)
if $LD --help 2>&1 | egrep ': supported targets:.* elf' > /dev/null; then
@@ -83,7 +80,7 @@ $FreeBSD$
else
ld_shlibs=no
fi
-@@ -1353,14 +1367,6 @@
+@@ -1359,14 +1373,6 @@
hardcode_shlibpath_var=no
;;
@@ -98,7 +95,7 @@ $FreeBSD$
hpux9* | hpux10* | hpux11*)
case "$host_os" in
hpux9*) archive_cmds='$rm $objdir/$soname~$LD -b +b $install_libdir -o $objdir/$soname $libobjs $deplibs $linkopts~test $objdir/$soname = $lib || mv $objdir/$soname $lib' ;;
-@@ -1775,7 +1781,7 @@
+@@ -1793,7 +1799,7 @@
version_type=none
dynamic_linker="$host_os ld.so"
sys_lib_dlsearch_path_spec="/lib /usr/lib"
@@ -107,7 +104,7 @@ $FreeBSD$
file_magic_cmd=
file_magic_test_file=
deplibs_check_method='unknown'
-@@ -1873,19 +1879,22 @@
+@@ -1891,19 +1897,22 @@
version_type=freebsd-$objformat
case "$version_type" in
freebsd-elf*)
@@ -127,7 +124,7 @@ $FreeBSD$
;;
esac
+ file_magic_cmd=/usr/bin/file
-+ file_magic_test_file=`echo /usr/lib/libc.so.*`
++ file_magic_test_file=`echo /usr/lib/libc.so*`
+ if test "$release_suffix" = all; then
+ library_names_spec='${libname}${release}.so$versuffix ${libname}${release}.so'
+ else
@@ -139,7 +136,7 @@ $FreeBSD$
shlibpath_var=LD_LIBRARY_PATH
case "$host_os" in
freebsd2* | freebsd3.[01]* | freebsdelf3.[01]*)
-@@ -2776,6 +2785,15 @@
+@@ -2812,6 +2821,15 @@
# Shell to use when invoking shell scripts.
SHELL=$LTSHELL
diff --git a/devel/libtool13/files/patch-ad b/devel/libtool13/files/patch-ad
index 3ec71700ffbb..304e840caaa9 100644
--- a/devel/libtool13/files/patch-ad
+++ b/devel/libtool13/files/patch-ad
@@ -1,8 +1,5 @@
-
-$FreeBSD$
-
---- ltmain.sh.orig Tue Dec 7 23:50:49 1999
-+++ ltmain.sh Thu May 2 10:24:05 2002
+--- ltmain.sh.orig Sat May 27 07:15:01 2000
++++ ltmain.sh Fri Dec 13 23:50:12 2002
@@ -23,6 +23,9 @@
# configuration script generated by Autoconf, you may include it under
# the same distribution terms that you use for the rest of that program.
@@ -17,20 +14,19 @@ $FreeBSD$
# Constants.
PROGRAM=ltmain.sh
PACKAGE=libtool
--VERSION=1.3.4
-+VERSION=1.3.4-freebsd-ports
- TIMESTAMP=" (1.385.2.196 1999/12/07 21:47:57)"
+-VERSION=1.3.5
++VERSION=1.3.5-freebsd-ports
+ TIMESTAMP=" (1.385.2.206 2000/05/27 11:12:27)"
default_mode=
@@ -952,7 +955,11 @@
continue
;;
release)
-- release="-$arg"
+ if test "$release_suffix" = all; then
+ release="$arg"
+ elif test "$release_suffix" = yes; then
-+ release="-$arg"
+ release="-$arg"
+ fi
prev=
continue
@@ -76,9 +72,9 @@ $FreeBSD$
if test -n "$dlfiles$dlprefiles" || test "$dlself" != no; then
$echo "$modename: warning: \`-dlopen' is ignored for libtool libraries" 1>&2
fi
-@@ -1795,6 +1801,9 @@
- *-*-cygwin* | *-*-mingw* | *-*-os2* | *-*-beos*)
- # these systems don't actually have a c library (as such)!
+@@ -1799,6 +1805,9 @@
+ # rhapsody is a little odd...
+ deplibs="$deplibs -framework System"
;;
+ *-*-freebsd*)
+ # FreeBSD doesn't need this...
@@ -86,7 +82,7 @@ $FreeBSD$
*)
# Add libc to deplibs on all other systems.
deplibs="$deplibs -lc"
-@@ -1802,6 +1811,94 @@
+@@ -1806,6 +1815,94 @@
esac
fi
@@ -181,63 +177,56 @@ $FreeBSD$
# Create the output directory, or remove our outputs if we need to.
if test -d $output_objdir; then
$show "${rm}r $output_objdir/$outputname $output_objdir/$libname.* $output_objdir/${libname}${release}.*"
-@@ -1817,7 +1914,11 @@
+@@ -1821,7 +1918,11 @@
# Now set the variables for building old libraries.
if test "$build_old_libs" = yes && test "$build_libtool_libs" != convenience ; then
-- oldlibs="$oldlibs $output_objdir/$libname.$libext"
+ if test "$release_suffix" = all; then
+ oldlibs="$oldlibs $output_objdir/$libname$release.$libext"
+ else
-+ oldlibs="$oldlibs $output_objdir/$libname.$libext"
+ oldlibs="$oldlibs $output_objdir/$libname.$libext"
+ fi
# Transform .lo files to .o files.
oldobjs="$objs "`$echo "X$libobjs" | $SP2NL | $Xsed -e '/\.'${libext}'$/d' -e "$lo2o" | $NL2SP`
-@@ -2011,7 +2112,11 @@
+@@ -2015,7 +2116,11 @@
echo "*** \`nm' from GNU binutils and a full rebuild may help."
fi
if test "$build_old_libs" = no; then
-- oldlibs="$output_objdir/$libname.$libext"
+ if test "$release_suffix" = all; then
+ oldlibs="$output_objdir/$libname$release.$libext"
+ else
-+ oldlibs="$output_objdir/$libname.$libext"
+ oldlibs="$output_objdir/$libname.$libext"
+ fi
build_libtool_libs=module
build_old_libs=yes
else
-@@ -3059,7 +3164,11 @@
+@@ -3071,7 +3176,11 @@
case "$output" in
*.la)
old_library=
-- test "$build_old_libs" = yes && old_library="$libname.$libext"
+ if test "$release_suffix" = all; then
+ test "$build_old_libs" = yes && old_library="$libname$release.$libext"
+ else
-+ test "$build_old_libs" = yes && old_library="$libname.$libext"
+ test "$build_old_libs" = yes && old_library="$libname.$libext"
+ fi
$show "creating $output"
if test -n "$xrpath"; then
-@@ -3348,10 +3457,12 @@
+@@ -3360,10 +3469,12 @@
fi
# Install the pseudo-library for information purposes.
-- name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
-- instname="$dir/$name"i
-- $show "$install_prog $instname $destdir/$name"
-- $run eval "$install_prog $instname $destdir/$name" || exit $?
+ if test "$install_ltlibs" = yes; then
-+ name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
-+ instname="$dir/$name"i
-+ $show "$install_prog $instname $destdir/$name"
-+ $run eval "$install_prog $instname $destdir/$name" || exit $?
+ name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
+ instname="$dir/$name"i
+ $show "$install_prog $instname $destdir/$name"
+ $run eval "$install_prog $instname $destdir/$name" || exit $?
+ fi
# Maybe install the static library, too.
test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
-@@ -3440,7 +3551,6 @@
+@@ -3452,7 +3563,6 @@
fi
libfile="$libdir/`$echo "X$lib" | $Xsed -e 's%^.*/%%g'`"
if test -n "$libdir" && test ! -f "$libfile"; then
diff --git a/devel/libtool13/files/patch-ae b/devel/libtool13/files/patch-ae
index c92b003b58cd..ffd4cff4c7db 100644
--- a/devel/libtool13/files/patch-ae
+++ b/devel/libtool13/files/patch-ae
@@ -1,6 +1,18 @@
---- configure.orig Fri Jul 2 09:01:56 1999
-+++ configure Tue Aug 31 23:45:29 1999
-@@ -1853,10 +1853,6 @@
+
+$FreeBSD$
+
+--- configure.orig Tue Dec 7 15:22:41 1999
++++ configure Mon Jan 14 16:21:53 2002
+@@ -702,7 +702,7 @@
+ fi
+
+
+-PACKAGE=libtool
++PACKAGE=libtool13
+
+ VERSION=1.3.5
+
+@@ -1859,10 +1859,6 @@
*) # Relative path.
ac_sub_cache_file="$ac_dots$cache_file" ;;
esac
diff --git a/devel/libtool13/files/patch-af b/devel/libtool13/files/patch-af
index beb6be3b456f..935b056b3c39 100644
--- a/devel/libtool13/files/patch-af
+++ b/devel/libtool13/files/patch-af
@@ -1,5 +1,8 @@
---- libltdl/Makefile.in.orig Tue Dec 7 13:03:38 1999
-+++ libltdl/Makefile.in Mon Jan 17 16:35:34 2000
+
+$FreeBSD$
+
+--- libltdl/Makefile.in.orig Tue Dec 7 15:03:38 1999
++++ libltdl/Makefile.in Mon Jan 14 17:05:36 2002
@@ -326,17 +326,16 @@
distdir: $(DISTFILES)
-rm -rf $(distdir)
@@ -22,3 +25,24 @@
info-am:
info: info-am
dvi-am:
+@@ -435,15 +434,15 @@
+ $(SHELL) ./config.status --recheck
+
+ local-install-files: $(DISTFILES)
+- -rm -rf $(DESTDIR)$(datadir)/libtool/libltdl
+- $(mkinstalldirs) $(DESTDIR)$(datadir)/libtool/libltdl
++ -rm -rf $(DESTDIR)$(datadir)/libtool13/libltdl
++ $(mkinstalldirs) $(DESTDIR)$(datadir)/libtool13/libltdl
+ @for file in $(DISTFILES); do \
+ d=$(srcdir); \
+ if test -d $$d/$$file; then \
+- cp -r $$d/$$file $(DESTDIR)$(datadir)/libtool/libltdl/$$file; \
++ cp -r $$d/$$file $(DESTDIR)$(datadir)/libtool13/libltdl/$$file; \
+ else \
+- test -f $(DESTDIR)$(datadir)/libtool/libltdl/$$file \
+- || cp $$d/$$file $(DESTDIR)$(datadir)/libtool/libltdl/$$file || :; \
++ test -f $(DESTDIR)$(datadir)/libtool13/libltdl/$$file \
++ || cp $$d/$$file $(DESTDIR)$(datadir)/libtool13/libltdl/$$file || :; \
+ fi; \
+ done
+
diff --git a/devel/libtool13/files/patch-ag b/devel/libtool13/files/patch-ag
deleted file mode 100644
index 5fdcd1924641..000000000000
--- a/devel/libtool13/files/patch-ag
+++ /dev/null
@@ -1,14 +0,0 @@
-
-$FreeBSD$
-
---- libltdl/configure 2001/01/31 10:58:38 1.1
-+++ libltdl/configure 2001/01/31 10:59:14
-@@ -1455,7 +1455,7 @@
- esac
-
- # Check for any special flags to pass to ltconfig.
--libtool_flags="--cache-file=$cache_file"
-+libtool_flags="--cache-file=$cache_file --disable-ltlibs"
- test "$enable_shared" = no && libtool_flags="$libtool_flags --disable-shared"
- test "$enable_static" = no && libtool_flags="$libtool_flags --disable-static"
- test "$enable_fast_install" = no && libtool_flags="$libtool_flags --disable-fast-install"
diff --git a/devel/libtool13/files/patch-libtoolize.in b/devel/libtool13/files/patch-libtoolize.in
new file mode 100644
index 000000000000..ec80fc6ea6c3
--- /dev/null
+++ b/devel/libtool13/files/patch-libtoolize.in
@@ -0,0 +1,14 @@
+
+$FreeBSD$
+
+--- libtoolize.in.orig Tue Mar 30 13:25:27 1999
++++ libtoolize.in Mon Jan 14 16:26:55 2002
+@@ -37,7 +37,7 @@
+ pkgdatadir=@pkgdatadir@
+ aclocaldir=@aclocaldir@
+
+-libtool_m4="$aclocaldir/libtool.m4"
++libtool_m4="$aclocaldir/libtool13.m4"
+
+ dry_run=no
+ help="Try \`$progname --help' for more information."
diff --git a/devel/libtool13/pkg-plist b/devel/libtool13/pkg-plist
index f057cdf134b2..6ec0729c163b 100644
--- a/devel/libtool13/pkg-plist
+++ b/devel/libtool13/pkg-plist
@@ -1,29 +1,30 @@
-bin/libtool
-bin/libtoolize
-include/ltdl.h
-@unexec install-info --delete %D/info/libtool.info %D/info/dir
-info/libtool.info
-@exec install-info %D/info/libtool.info %D/info/dir
-lib/libltdl.a
-lib/libltdl.so
-lib/libltdl.so.1
-share/aclocal/libtool.m4
-share/libtool/config.guess
-share/libtool/config.sub
-share/libtool/libltdl/COPYING.LIB
-share/libtool/libltdl/Makefile.am
-share/libtool/libltdl/Makefile.in
-share/libtool/libltdl/README
-share/libtool/libltdl/acconfig.h
-share/libtool/libltdl/acinclude.m4
-share/libtool/libltdl/aclocal.m4
-share/libtool/libltdl/config.h.in
-share/libtool/libltdl/configure
-share/libtool/libltdl/configure.in
-share/libtool/libltdl/ltdl.c
-share/libtool/libltdl/ltdl.h
-share/libtool/libltdl/stamp-h.in
-share/libtool/ltconfig
-share/libtool/ltmain.sh
-@dirrm share/libtool/libltdl
-@dirrm share/libtool
+@comment $FreeBSD$
+bin/libtool13
+bin/libtoolize13
+libexec/libtool13/libtool
+libexec/libtool13/libtoolize
+@unexec install-info --delete %D/info/libtool13.info %D/info/dir
+info/libtool13.info
+@exec install-info %D/info/libtool13.info %D/info/dir
+share/aclocal/libtool13.m4
+share/libtool13/config.guess
+share/libtool13/config.sub
+share/libtool13/libltdl/README
+share/libtool13/libltdl/stamp-h.in
+share/libtool13/libltdl/COPYING.LIB
+share/libtool13/libltdl/Makefile.am
+share/libtool13/libltdl/Makefile.in
+share/libtool13/libltdl/acconfig.h
+share/libtool13/libltdl/acinclude.m4
+share/libtool13/libltdl/aclocal.m4
+share/libtool13/libltdl/config.h.in
+share/libtool13/libltdl/configure
+share/libtool13/libltdl/configure.in
+share/libtool13/libltdl/ltdl.c
+share/libtool13/libltdl/ltdl.h
+share/libtool13/ltconfig
+share/libtool13/ltconfig13
+share/libtool13/ltmain.sh
+@dirrm share/libtool13/libltdl
+@dirrm share/libtool13
+@dirrm libexec/libtool13