aboutsummaryrefslogtreecommitdiff
path: root/devel/libtool22/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/libtool22/Makefile')
-rw-r--r--devel/libtool22/Makefile20
1 files changed, 14 insertions, 6 deletions
diff --git a/devel/libtool22/Makefile b/devel/libtool22/Makefile
index 6bc23f393c68..949e0de17534 100644
--- a/devel/libtool22/Makefile
+++ b/devel/libtool22/Makefile
@@ -6,24 +6,32 @@
#
PORTNAME?= libtool
-PORTVERSION= 2.2.6b
+PORTVERSION= 2.2.10
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= libtool
DISTNAME= libtool-${PORTVERSION}
-EXTRACT_SUFX= .tar.lzma
-MAINTAINER= kwm@FreeBSD.org
+MAINTAINER= autotools@FreeBSD.org
COMMENT?= Generic shared library support script
-WRKSRC= ${WRKDIR}/libtool-${PORTVERSION:S|a||}
-USE_XZ= yes
+LICENSE?= GPLv2
+LICENSE_FILE?= ${WRKSRC}/COPYING
+
GNU_CONFIGURE= yes
CONFIGURE_ARGS?= --disable-ltdl-install
CONFIGURE_ENV= MAKEINFO="makeinfo --no-split"
INFO?= libtool
+.if ${PORTNAME} != "libltdl"
+MAN1= libtool.1 libtoolize.1
+.endif
post-patch:
- ${REINPLACE_CMD} -e 's|sed gsed|sed|g' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|sed gsed|sed|g' \
+ -e 's|CC=cc|CC=${CC}|g' \
+ ${WRKSRC}/configure ${WRKSRC}/libltdl/configure
+
+post-configure:
+ @${FIND} ${WRKSRC} -type f | ${XARGS} ${TOUCH} -f
.include <bsd.port.mk>