aboutsummaryrefslogtreecommitdiff
path: root/devel/libzvbi/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/libzvbi/Makefile')
-rw-r--r--devel/libzvbi/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/devel/libzvbi/Makefile b/devel/libzvbi/Makefile
index 9febc17a23be..7b567b86b4b0 100644
--- a/devel/libzvbi/Makefile
+++ b/devel/libzvbi/Makefile
@@ -12,7 +12,7 @@ MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= zapping
DISTNAME= ${PORTNAME:S/lib//}-${PORTVERSION}
-MAINTAINER= oliver@freebsd.org
+MAINTAINER= oliver@FreeBSD.org
COMMENT= Routines to access raw VBI capture devices
LIB_DEPENDS+= png.5:${PORTSDIR}/graphics/png \
@@ -21,12 +21,14 @@ LIB_DEPENDS+= png.5:${PORTSDIR}/graphics/png \
USE_X_PREFIX= yes
USE_BZIP2= yes
USE_REINPLACE= yes
+USE_LIBTOOL= yes
GNU_CONFIGURE= yes
+INSTALLS_SHLIB= yes
CONFIGURE_ARGS= --with-libiconv-prefix=${LOCALBASE}/include \
--with-libintl-prefix=${LOCALBASE}/include
-CONFIGURE_ENV= CC="$(CC) -I${LOCALBASE}/include" LIBS="-L${LOCALBASE}/lib -L/usr/lib"
+CONFIGURE_ENV= CC="${CC} -I${LOCALBASE}/include" LIBS="-L${LOCALBASE}/lib -L/usr/lib"
post-patch:
@${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/configure