aboutsummaryrefslogtreecommitdiff
path: root/devel/linux-c7-systemd-libs/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/linux-c7-systemd-libs/Makefile')
-rw-r--r--devel/linux-c7-systemd-libs/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/devel/linux-c7-systemd-libs/Makefile b/devel/linux-c7-systemd-libs/Makefile
new file mode 100644
index 000000000000..f279682e1d6a
--- /dev/null
+++ b/devel/linux-c7-systemd-libs/Makefile
@@ -0,0 +1,25 @@
+# $FreeBSD$
+
+PORTNAME= systemd
+PORTVERSION= 219
+DISTVERSIONSUFFIX= -62.el7_6.9
+PORTREVISION= 1
+CATEGORIES= devel linux
+PKGNAMESUFFIX= -libs
+
+MAINTAINER= emulation@FreeBSD.org
+COMMENT= Libraries for accessing systemd (Linux CentOS ${LINUX_DIST_VER})
+
+LICENSE= LGPL21+
+
+USES= linux:c7
+USE_LDCONFIG= yes
+USE_LINUX= elfutils-libs libgcrypt libgpg-error lz4
+USE_LINUX_RPM= yes
+
+LIB_DISTNAMES= ${PORTNAME}${PKGNAMESUFFIX}-${DISTVERSIONFULL}
+
+post-patch:
+ @${RM} -r ${WRKSRC}/usr/lib*/libudev.so.* ${WRKSRC}/usr/lib*/security
+
+.include <bsd.port.mk>