aboutsummaryrefslogtreecommitdiff
path: root/devel/linux_devtools-7/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/linux_devtools-7/Makefile')
-rw-r--r--devel/linux_devtools-7/Makefile14
1 files changed, 7 insertions, 7 deletions
diff --git a/devel/linux_devtools-7/Makefile b/devel/linux_devtools-7/Makefile
index ce6e58a5ebc9..0973c16d1bd2 100644
--- a/devel/linux_devtools-7/Makefile
+++ b/devel/linux_devtools-7/Makefile
@@ -10,14 +10,14 @@ PORTVERSION= 7.1
PORTREVISION= 3
CATEGORIES= devel emulators linux
MASTER_SITES= ${MASTER_SITE_REDHAT_LINUX}
-MASTER_SITE_SUBDIR= ${PORTVERSION}/${LANG}/os/${ARCH}/RedHat/RPMS
+MASTER_SITE_SUBDIR= ${PORTVERSION}/${LANG}/os/${MACHINE_ARCH}/RedHat/RPMS
DISTFILES= ${RPM_MAKE} \
- binutils-2.10.91.0.2-3.${ARCH}.rpm \
+ binutils-2.10.91.0.2-3.${MACHINE_ARCH}.rpm \
${RPM_GDB}
EXTRACT_ONLY=
PATCH_SITES= ${MASTER_SITE_REDHAT_LINUX}
-PATCH_SITE_SUBDIR= updates/${PORTVERSION}/${LANG}/os/${ARCH}
+PATCH_SITE_SUBDIR= updates/${PORTVERSION}/${LANG}/os/${MACHINE_ARCH}
PATCHFILES= ${UPDATES}
MAINTAINER= freebsd-emulation@FreeBSD.org
@@ -37,21 +37,21 @@ NO_FILTER_SHLIBS= yes
NO_MTREE= yes
PLIST= ${WRKDIR}/plist
RESTRICTED= "binaries under GNU GPL without accompanying source"
-MD5_FILE= ${MASTERDIR}/distinfo.${ARCH}
+MD5_FILE= ${MASTERDIR}/distinfo.${MACHINE_ARCH}
# Let's avoid hardcoding 'en' as the language.
LANG= en
.include <bsd.port.pre.mk>
-.if (${ARCH} == "alpha")
+.if (${MACHINE_ARCH} == "alpha")
PATCH_SITES= \
ftp://ftp2.compaq.com/pub/linux/RedHat/7.2-alpha/updates/rpms/alpha/ \
ftp://alpha.crl.dec.com/pub/linux/redhat/7.2-alpha/updates/rpms/alpha/
PORTREVISION= 2
.endif
-.if (${ARCH} == "i386")
+.if (${MACHINE_ARCH} == "i386")
RPM_GDB= gdb-5.0rh-5.i386.rpm
RPM_MAKE= make-3.79.1-5.i386.rpm
UPDATES= XFree86-devel-4.1.0-50.i386.rpm \
@@ -94,7 +94,7 @@ pre-install:
cd ${WRKSRC}/tmp; rpm2cpio < ${DISTDIR}/${DIST_SUBDIR}/${ii} | cpio -id
.endfor
cd ${WRKSRC}/tmp; ${FIND} * -type f -o -type l > ${PLIST}
-.if (${ARCH} == "i386")
+.if (${MACHINE_ARCH} == "i386")
${ECHO_CMD} boot/kernel.h >> ${PLIST}
.endif
cd ${WRKSRC}/tmp; ${FIND} -d * -type d | ${GREP} -vE "man|locale" | \