aboutsummaryrefslogtreecommitdiff
path: root/devel/llvm-devel
diff options
context:
space:
mode:
Diffstat (limited to 'devel/llvm-devel')
-rw-r--r--devel/llvm-devel/Makefile11
-rw-r--r--devel/llvm-devel/Makefile.svn_rev2
-rw-r--r--devel/llvm-devel/distinfo6
-rw-r--r--devel/llvm-devel/pkg-plist33
4 files changed, 32 insertions, 20 deletions
diff --git a/devel/llvm-devel/Makefile b/devel/llvm-devel/Makefile
index 4c1bb9bd0e05..95ce3530590b 100644
--- a/devel/llvm-devel/Makefile
+++ b/devel/llvm-devel/Makefile
@@ -7,7 +7,6 @@
PORTNAME= llvm
DISTVERSION= 2.7.r${SVN_REV}
-PORTREVISION= 1
CATEGORIES= devel lang
MASTER_SITES= ${MASTER_SITE_LOCAL}
MASTER_SITE_SUBDIR= brooks
@@ -33,12 +32,18 @@ USE_LDCONFIG= yes
USE_PERL5= yes
USE_PYTHON_RUN= yes
MAKE_JOBS_SAFE= yes
-MAKE_ARGS= REQUIRES_RTTI=1
+
+# Suggested tweaks from http://llvm.org/docs/Packaging.html
+# Commented out ones are currently broken.
+MAKE_ARGS+= REQUIRES_RTTI=1
+#CONFIGURE_ARGS+= --enable-shared
.if defined(MAINTAINER_MODE)
CONFIGURE_ARGS+= --with-f2c=${LOCALBASE}
.else
-CONFIGURE_ARGS+= --enable-optimized
+CONFIGURE_ARGS+= --disable-assertions \
+ --enable-debug-symbols \
+ --enable-optimized
.endif
CONFIGURE_ARGS+= --enable-bindings=none
diff --git a/devel/llvm-devel/Makefile.svn_rev b/devel/llvm-devel/Makefile.svn_rev
index 34b4b68b2212..9f326da7cf2b 100644
--- a/devel/llvm-devel/Makefile.svn_rev
+++ b/devel/llvm-devel/Makefile.svn_rev
@@ -1 +1 @@
-SVN_REV= 96348
+SVN_REV= 97497
diff --git a/devel/llvm-devel/distinfo b/devel/llvm-devel/distinfo
index a50911f70d8e..31228091a79e 100644
--- a/devel/llvm-devel/distinfo
+++ b/devel/llvm-devel/distinfo
@@ -1,3 +1,3 @@
-MD5 (llvm-2.7.r96348.tar.bz2) = 98474354e50f0c91bbe75f384a2ebbf1
-SHA256 (llvm-2.7.r96348.tar.bz2) = ac73d9f665d90386aa9fe3d6a114d42f06bad567158a94f2c511ac7ebf829d55
-SIZE (llvm-2.7.r96348.tar.bz2) = 10495958
+MD5 (llvm-2.7.r97497.tar.bz2) = 410a508e376b64b8366773d9ae6b09de
+SHA256 (llvm-2.7.r97497.tar.bz2) = 8b7d906a1b77e1c926f407ab7d10ea9c6690b654172e3899d3cd56de6bcefd79
+SIZE (llvm-2.7.r97497.tar.bz2) = 10537249
diff --git a/devel/llvm-devel/pkg-plist b/devel/llvm-devel/pkg-plist
index 5a2344cfefb0..be4cef45c629 100644
--- a/devel/llvm-devel/pkg-plist
+++ b/devel/llvm-devel/pkg-plist
@@ -71,6 +71,7 @@ include/clang/AST/TypeVisitor.h
include/clang/AST/UnresolvedSet.h
include/clang/Analysis/Analyses/LiveVariables.h
include/clang/Analysis/Analyses/PrintfFormatString.h
+include/clang/Analysis/Analyses/ReachableCode.h
include/clang/Analysis/Analyses/UninitializedValues.h
include/clang/Analysis/AnalysisContext.h
include/clang/Analysis/AnalysisDiagnostic.h
@@ -110,15 +111,15 @@ include/clang/Basic/OperatorKinds.def
include/clang/Basic/OperatorKinds.h
include/clang/Basic/PartialDiagnostic.h
include/clang/Basic/PrettyStackTrace.h
-include/clang/Basic/Release/DiagnosticASTKinds.inc.tmp
-include/clang/Basic/Release/DiagnosticAnalysisKinds.inc.tmp
-include/clang/Basic/Release/DiagnosticCommonKinds.inc.tmp
-include/clang/Basic/Release/DiagnosticDriverKinds.inc.tmp
-include/clang/Basic/Release/DiagnosticFrontendKinds.inc.tmp
-include/clang/Basic/Release/DiagnosticGroups.inc.tmp
-include/clang/Basic/Release/DiagnosticLexKinds.inc.tmp
-include/clang/Basic/Release/DiagnosticParseKinds.inc.tmp
-include/clang/Basic/Release/DiagnosticSemaKinds.inc.tmp
+include/clang/Basic/Release+Debug/DiagnosticASTKinds.inc.tmp
+include/clang/Basic/Release+Debug/DiagnosticAnalysisKinds.inc.tmp
+include/clang/Basic/Release+Debug/DiagnosticCommonKinds.inc.tmp
+include/clang/Basic/Release+Debug/DiagnosticDriverKinds.inc.tmp
+include/clang/Basic/Release+Debug/DiagnosticFrontendKinds.inc.tmp
+include/clang/Basic/Release+Debug/DiagnosticGroups.inc.tmp
+include/clang/Basic/Release+Debug/DiagnosticLexKinds.inc.tmp
+include/clang/Basic/Release+Debug/DiagnosticParseKinds.inc.tmp
+include/clang/Basic/Release+Debug/DiagnosticSemaKinds.inc.tmp
include/clang/Basic/SourceLocation.h
include/clang/Basic/SourceManager.h
include/clang/Basic/SourceManagerInternals.h
@@ -182,8 +183,8 @@ include/clang/Driver/Option.h
include/clang/Driver/Options.h
include/clang/Driver/Options.inc
include/clang/Driver/Phases.h
-include/clang/Driver/Release/CC1Options.inc.tmp
-include/clang/Driver/Release/Options.inc.tmp
+include/clang/Driver/Release+Debug/CC1Options.inc.tmp
+include/clang/Driver/Release+Debug/Options.inc.tmp
include/clang/Driver/Tool.h
include/clang/Driver/ToolChain.h
include/clang/Driver/Types.def
@@ -194,6 +195,7 @@ include/clang/Frontend/ASTUnit.h
include/clang/Frontend/Analyses.def
include/clang/Frontend/AnalysisConsumer.h
include/clang/Frontend/ChainedDiagnosticClient.h
+include/clang/Frontend/CodeGenAction.h
include/clang/Frontend/CommandLineSourceLoc.h
include/clang/Frontend/CompilerInstance.h
include/clang/Frontend/CompilerInvocation.h
@@ -627,6 +629,7 @@ include/llvm/System/TimeValue.h
include/llvm/Target/Mangler.h
include/llvm/Target/SubtargetFeature.h
include/llvm/Target/Target.td
+include/llvm/Target/TargetAsmBackend.h
include/llvm/Target/TargetAsmLexer.h
include/llvm/Target/TargetAsmParser.h
include/llvm/Target/TargetCallingConv.td
@@ -715,6 +718,9 @@ lib/libLLVMInstrumentation.a
lib/libLLVMInterpreter.a
lib/libLLVMJIT.a
lib/libLLVMLinker.a
+lib/libLLVMMBlazeAsmPrinter.a
+lib/libLLVMMBlazeCodeGen.a
+lib/libLLVMMBlazeInfo.a
lib/libLLVMMC.a
lib/libLLVMMCParser.a
lib/libLLVMMSIL.a
@@ -832,6 +838,7 @@ lib/libprofile_rt.so
%%DOCSDIR%%/html/MakefileGuide.html
%%DOCSDIR%%/html/PCHInternals.html
%%DOCSDIR%%/html/PTHInternals.html
+%%DOCSDIR%%/html/Packaging.html
%%DOCSDIR%%/html/Passes.html
%%DOCSDIR%%/html/ProgrammersManual.html
%%DOCSDIR%%/html/Projects.html
@@ -921,7 +928,7 @@ lib/libprofile_rt.so
@dirrm include/clang/Lex
@dirrm include/clang/Index
@dirrm include/clang/Frontend
-@dirrm include/clang/Driver/Release
+@dirrm include/clang/Driver/Release+Debug
@dirrm include/clang/Driver
@dirrm include/clang/CodeGen
@dirrm include/clang/Checker/PathSensitive
@@ -929,7 +936,7 @@ lib/libprofile_rt.so
@dirrm include/clang/Checker/Checkers
@dirrm include/clang/Checker/BugReporter
@dirrm include/clang/Checker
-@dirrm include/clang/Basic/Release
+@dirrm include/clang/Basic/Release+Debug
@dirrm include/clang/Basic
@dirrm include/clang/Analysis/Visitors
@dirrm include/clang/Analysis/Support