aboutsummaryrefslogtreecommitdiff
path: root/devel/llvm29/pkg-plist
diff options
context:
space:
mode:
Diffstat (limited to 'devel/llvm29/pkg-plist')
-rw-r--r--devel/llvm29/pkg-plist36
1 files changed, 33 insertions, 3 deletions
diff --git a/devel/llvm29/pkg-plist b/devel/llvm29/pkg-plist
index 24f8485f0b03..e8c75d87abb0 100644
--- a/devel/llvm29/pkg-plist
+++ b/devel/llvm29/pkg-plist
@@ -26,18 +26,27 @@ etc/llvm/cpp
etc/llvm/cxx
etc/llvm/ll
etc/llvm/st
+include/llvm-c/Analysis.h
+include/llvm-c/BitReader.h
+include/llvm-c/BitWriter.h
+include/llvm-c/Core.h
+include/llvm-c/ExecutionEngine.h
include/llvm-c/LinkTimeOptimizer.h
include/llvm/ADT/APFloat.h
include/llvm/ADT/APInt.h
include/llvm/ADT/APSInt.h
include/llvm/ADT/BitVector.h
include/llvm/ADT/DenseMap.h
+include/llvm/ADT/DenseSet.h
include/llvm/ADT/DepthFirstIterator.h
include/llvm/ADT/EquivalenceClasses.h
include/llvm/ADT/FoldingSet.h
include/llvm/ADT/GraphTraits.h
include/llvm/ADT/HashExtras.h
+include/llvm/ADT/ImmutableMap.h
+include/llvm/ADT/ImmutableSet.h
include/llvm/ADT/IndexedMap.h
+include/llvm/ADT/OwningPtr.h
include/llvm/ADT/PostOrderIterator.h
include/llvm/ADT/SCCIterator.h
include/llvm/ADT/STLExtras.h
@@ -52,6 +61,7 @@ include/llvm/ADT/Statistic.h
include/llvm/ADT/StringExtras.h
include/llvm/ADT/StringMap.h
include/llvm/ADT/Tree.h
+include/llvm/ADT/Trie.h
include/llvm/ADT/UniqueVector.h
include/llvm/ADT/VectorExtras.h
include/llvm/ADT/hash_map
@@ -65,6 +75,7 @@ include/llvm/Analysis/CFGPrinter.h
include/llvm/Analysis/CallGraph.h
include/llvm/Analysis/ConstantFolding.h
include/llvm/Analysis/ConstantsScanner.h
+include/llvm/Analysis/DominatorInternals.h
include/llvm/Analysis/Dominators.h
include/llvm/Analysis/FindUsedTypes.h
include/llvm/Analysis/Interval.h
@@ -96,12 +107,20 @@ include/llvm/Bitcode/Archive.h
include/llvm/Bitcode/BitCodes.h
include/llvm/Bitcode/BitstreamReader.h
include/llvm/Bitcode/BitstreamWriter.h
+include/llvm/Bitcode/Deserialize.h
include/llvm/Bitcode/LLVMBitCodes.h
include/llvm/Bitcode/ReaderWriter.h
+include/llvm/Bitcode/Serialization.h
+include/llvm/Bitcode/SerializationFwd.h
+include/llvm/Bitcode/Serialize.h
include/llvm/CallGraphSCCPass.h
include/llvm/CallingConv.h
include/llvm/CodeGen/AsmPrinter.h
+include/llvm/CodeGen/BreakCriticalMachineEdge.h
include/llvm/CodeGen/CallingConvLower.h
+include/llvm/CodeGen/Collector.h
+include/llvm/CodeGen/CollectorMetadata.h
+include/llvm/CodeGen/Collectors.h
include/llvm/CodeGen/DwarfWriter.h
include/llvm/CodeGen/ELFRelocation.h
include/llvm/CodeGen/FileWriters.h
@@ -114,6 +133,7 @@ include/llvm/CodeGen/MachORelocation.h
include/llvm/CodeGen/MachineBasicBlock.h
include/llvm/CodeGen/MachineCodeEmitter.h
include/llvm/CodeGen/MachineConstantPool.h
+include/llvm/CodeGen/MachineDominators.h
include/llvm/CodeGen/MachineFrameInfo.h
include/llvm/CodeGen/MachineFunction.h
include/llvm/CodeGen/MachineFunctionPass.h
@@ -121,22 +141,23 @@ include/llvm/CodeGen/MachineInstr.h
include/llvm/CodeGen/MachineInstrBuilder.h
include/llvm/CodeGen/MachineJumpTableInfo.h
include/llvm/CodeGen/MachineLocation.h
+include/llvm/CodeGen/MachineLoopInfo.h
include/llvm/CodeGen/MachineModuleInfo.h
+include/llvm/CodeGen/MachineOperand.h
include/llvm/CodeGen/MachinePassRegistry.h
+include/llvm/CodeGen/MachineRegisterInfo.h
include/llvm/CodeGen/MachineRelocation.h
include/llvm/CodeGen/Passes.h
include/llvm/CodeGen/RegAllocRegistry.h
include/llvm/CodeGen/RegisterCoalescer.h
include/llvm/CodeGen/RegisterScavenging.h
include/llvm/CodeGen/RuntimeLibcalls.h
-include/llvm/CodeGen/SSARegMap.h
include/llvm/CodeGen/SchedGraphCommon.h
include/llvm/CodeGen/ScheduleDAG.h
include/llvm/CodeGen/SchedulerRegistry.h
include/llvm/CodeGen/SelectionDAG.h
include/llvm/CodeGen/SelectionDAGISel.h
include/llvm/CodeGen/SelectionDAGNodes.h
-include/llvm/CodeGen/SimpleRegisterCoalescing.h
include/llvm/CodeGen/ValueTypes.h
include/llvm/CodeGen/ValueTypes.td
include/llvm/Config/alloca.h
@@ -154,6 +175,7 @@ include/llvm/ExecutionEngine/ExecutionEngine.h
include/llvm/ExecutionEngine/GenericValue.h
include/llvm/ExecutionEngine/Interpreter.h
include/llvm/ExecutionEngine/JIT.h
+include/llvm/ExecutionEngine/JITMemoryManager.h
include/llvm/Function.h
include/llvm/GlobalAlias.h
include/llvm/GlobalValue.h
@@ -167,6 +189,8 @@ include/llvm/IntrinsicInst.h
include/llvm/Intrinsics.gen
include/llvm/Intrinsics.h
include/llvm/Intrinsics.td
+include/llvm/IntrinsicsARM.td
+include/llvm/IntrinsicsCellSPU.td
include/llvm/IntrinsicsPowerPC.td
include/llvm/IntrinsicsX86.td
include/llvm/LinkAllPasses.h
@@ -182,6 +206,7 @@ include/llvm/PassManager.h
include/llvm/PassManagers.h
include/llvm/PassSupport.h
include/llvm/Support/AIXDataTypesFix.h
+include/llvm/Support/AlignOf.h
include/llvm/Support/Allocator.h
include/llvm/Support/Annotation.h
include/llvm/Support/CFG.h
@@ -212,17 +237,19 @@ include/llvm/Support/OutputBuffer.h
include/llvm/Support/PassNameParser.h
include/llvm/Support/PatternMatch.h
include/llvm/Support/PluginLoader.h
+include/llvm/Support/Registry.h
include/llvm/Support/SlowOperationInformer.h
include/llvm/Support/StableBasicBlockNumbering.h
include/llvm/Support/Streams.h
+include/llvm/Support/StringPool.h
include/llvm/Support/SystemUtils.h
include/llvm/Support/Timer.h
-include/llvm/Support/TypeInfo.h
include/llvm/Support/type_traits.h
include/llvm/SymbolTableListTraits.h
include/llvm/System/Alarm.h
include/llvm/System/Disassembler.h
include/llvm/System/DynamicLibrary.h
+include/llvm/System/Host.h
include/llvm/System/IncludeFile.h
include/llvm/System/LICENSE.TXT
include/llvm/System/MappedFile.h
@@ -239,6 +266,7 @@ include/llvm/Target/TargetAsmInfo.h
include/llvm/Target/TargetData.h
include/llvm/Target/TargetELFWriterInfo.h
include/llvm/Target/TargetFrameInfo.h
+include/llvm/Target/TargetInstrDesc.h
include/llvm/Target/TargetInstrInfo.h
include/llvm/Target/TargetInstrItineraries.h
include/llvm/Target/TargetJITInfo.h
@@ -261,6 +289,7 @@ include/llvm/Transforms/Utils/InlineCost.h
include/llvm/Transforms/Utils/Local.h
include/llvm/Transforms/Utils/PromoteMemToReg.h
include/llvm/Transforms/Utils/UnifyFunctionExitNodes.h
+include/llvm/Transforms/Utils/ValueMapper.h
include/llvm/Type.h
include/llvm/TypeSymbolTable.h
include/llvm/Use.h
@@ -270,6 +299,7 @@ include/llvm/ValueSymbolTable.h
lib/LLVMARM.o
lib/LLVMAlpha.o
lib/LLVMCBackend.o
+lib/LLVMCellSPU.o
lib/LLVMExecutionEngine.o
lib/LLVMHello.a
lib/LLVMHello.la