aboutsummaryrefslogtreecommitdiff
path: root/devel/lua-posix/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/lua-posix/Makefile')
-rw-r--r--devel/lua-posix/Makefile10
1 files changed, 9 insertions, 1 deletions
diff --git a/devel/lua-posix/Makefile b/devel/lua-posix/Makefile
index 37ec1872664c..02a45b1d6d89 100644
--- a/devel/lua-posix/Makefile
+++ b/devel/lua-posix/Makefile
@@ -15,12 +15,20 @@ DISTFILES= lposix.tar.gz
MAINTAINER= andrew+ports@fubar.geek.nz
COMMENT= A POSIX layer for Lua
-USE_LUA= 5.0
+USE_LUA?= 5.1
WRKSRC= ${WRKDIR}/posix
PLIST_FILES= %%LUA_MODSHAREDIR%%/posix.lua \
%%LUA_MODLIBDIR%%/lposix.so
+.if ${USE_LUA} == 5.1
+EXTRA_PATCHES= ${FILESDIR}/extrapatch-51-lposix.c \
+ ${FILESDIR}/extrapatch-51-posix.lua \
+ ${FILESDIR}/extrapatch-51-test.lua
+.elif ${USE_LUA} == 5.0
+EXTRA_PATCHES= ${FILESDIR}/extrapatch-50-Makefile
+.endif
+
do-install:
@${INSTALL_DATA} ${WRKSRC}/posix.lua ${LUA_MODSHAREDIR}
@${INSTALL_PROGRAM} ${WRKSRC}/lposix.so ${LUA_MODLIBDIR}