aboutsummaryrefslogtreecommitdiff
path: root/devel/lua-posix
diff options
context:
space:
mode:
Diffstat (limited to 'devel/lua-posix')
-rw-r--r--devel/lua-posix/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/devel/lua-posix/Makefile b/devel/lua-posix/Makefile
index 22a25ae0b63b..5d5ef3990712 100644
--- a/devel/lua-posix/Makefile
+++ b/devel/lua-posix/Makefile
@@ -21,16 +21,21 @@ WRKSRC= ${WRKDIR}/posix
PLIST_FILES= %%LUA_MODSHAREDIR%%/posix.lua \
%%LUA_MODLIBDIR%%/lposix.so
+.include <bsd.port.pre.mk>
+
.if ${USE_LUA} == 5.1
EXTRA_PATCHES= ${FILESDIR}/extrapatch-51-lposix.c \
${FILESDIR}/extrapatch-51-posix.lua \
${FILESDIR}/extrapatch-51-test.lua
.elif ${USE_LUA} == 5.0
EXTRA_PATCHES= ${FILESDIR}/extrapatch-50-Makefile
+.if ${ARCH} == "powerpc"
+BROKEN= Does not compile on powerpc
+.endif
.endif
do-install:
@${INSTALL_DATA} ${WRKSRC}/posix.lua ${LUA_MODSHAREDIR}
@${INSTALL_PROGRAM} ${WRKSRC}/lposix.so ${LUA_MODLIBDIR}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>