aboutsummaryrefslogtreecommitdiff
path: root/devel/luabind/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/luabind/Makefile')
-rw-r--r--devel/luabind/Makefile46
1 files changed, 46 insertions, 0 deletions
diff --git a/devel/luabind/Makefile b/devel/luabind/Makefile
new file mode 100644
index 000000000000..47a6473e4af7
--- /dev/null
+++ b/devel/luabind/Makefile
@@ -0,0 +1,46 @@
+# New ports collection makefile for: luabind
+# Date created: 06 Jun 2007
+# Whom: Dmitry Marakasov <amdmi3@amdmi3.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= luabind
+PORTVERSION= 0.7
+CATEGORIES= devel
+MASTER_SITES= SF
+
+MAINTAINER= amdmi3@amdmi3.ru
+COMMENT= Library that helps you create bindings between C++ and Lua
+
+BUILD_DEPENDS= ${LOCALBASE}/include/boost/python/detail/is_xxx.hpp:${PORTSDIR}/devel/boost-python
+RUN_DEPENDS= ${LOCALBASE}/include/boost/python/detail/is_xxx.hpp:${PORTSDIR}/devel/boost-python
+
+USE_ZIP= yes
+USE_LUA= 5.0
+USE_GMAKE= yes
+
+MAKE_ENV= CXX="${CXX}" LUA_INCDIR="${LUA_INCDIR}" \
+ BOOST_ROOT="${LOCALBASE}/include"
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+BUILD_WRKSRC= ${WRKSRC}/src
+
+MAKEFILE= makefile
+
+PORTDOCS= *
+
+post-patch:
+ ${MKDIR} ${WRKSRC}/lib
+
+do-install:
+ ${INSTALL_DATA} ${WRKSRC}/lib/libluabind.a ${PREFIX}/lib
+ (cd ${WRKSRC} && ${COPYTREE_SHARE} luabind ${PREFIX}/include)
+
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ (cd ${WRKSRC}/doc && ${COPYTREE_SHARE} \* ${DOCSDIR})
+.endif
+
+.include <bsd.port.mk>