aboutsummaryrefslogtreecommitdiff
path: root/devel/m6811-gcc/files
diff options
context:
space:
mode:
Diffstat (limited to 'devel/m6811-gcc/files')
-rw-r--r--devel/m6811-gcc/files/patch-aa24
-rw-r--r--devel/m6811-gcc/files/patch-ab127
-rw-r--r--devel/m6811-gcc/files/patch-ac82
-rw-r--r--devel/m6811-gcc/files/patch-ad7
4 files changed, 0 insertions, 240 deletions
diff --git a/devel/m6811-gcc/files/patch-aa b/devel/m6811-gcc/files/patch-aa
deleted file mode 100644
index 6932d783f191..000000000000
--- a/devel/m6811-gcc/files/patch-aa
+++ /dev/null
@@ -1,24 +0,0 @@
-*** Makefile.orig Fri Sep 1 16:59:32 1995
---- Makefile Fri Sep 1 17:14:52 1995
-***************
-*** 0 ****
---- 1,19 ----
-+
-+ all:
-+ cd gcc-2.6.3; ${MAKE} "LANGUAGES=c" $@
-+ cd gcc-6811-release/xasm/asm-src; ${MAKE}
-+ cd gcc-6811-release/xasm/lnk-src; ${MAKE}
-+ cd gcc-6811-release/sample; ${MAKE}
-+
-+ install:
-+ cd gcc-2.6.3; ${MAKE} "LANGUAGES=c" $@
-+ cd gcc-6811-release/xasm/asm-src; ${MAKE} $@
-+ cd gcc-6811-release/xasm/lnk-src; ${MAKE} $@
-+ cd gcc-6811-release/sample; ${MAKE} $@
-+ cd ${PREFIX}/lib/gcc-lib/m6811-local/2.6.3; \
-+ rm -f as ld; \
-+ ln -s ${PREFIX}/bin/as6811 as; \
-+ ln -s ${PREFIX}/bin/aslink ld
-+ rm -f ${PREFIX}/bin/gcc11
-+ cd ${PREFIX}/bin; ln -s ${PREFIX}/bin/m6811-local-gcc gcc11
-+
diff --git a/devel/m6811-gcc/files/patch-ab b/devel/m6811-gcc/files/patch-ab
deleted file mode 100644
index 93fdb61fcb2c..000000000000
--- a/devel/m6811-gcc/files/patch-ab
+++ /dev/null
@@ -1,127 +0,0 @@
-*** gcc-2.6.3/Makefile.in~ Fri Sep 1 11:18:23 1995
---- gcc-2.6.3/Makefile.in Fri Sep 1 11:18:33 1995
-***************
-*** 34,40 ****
-
- # Selection of languages to be made.
- # This is overridden by configure.
-! LANGUAGES = c objective-c proto
-
- ALLOCA =
- ALLOCA_FLAGS =
---- 34,40 ----
-
- # Selection of languages to be made.
- # This is overridden by configure.
-! LANGUAGES = c
-
- ALLOCA =
- ALLOCA_FLAGS =
-***************
-*** 319,325 ****
- HOST_OBSTACK=$(OBSTACK)
-
- # Choose the real default target.
-! ALL=all.internal
-
- # Choose the real install target.
- INSTALL_TARGET=install-normal
---- 319,325 ----
- HOST_OBSTACK=$(OBSTACK)
-
- # Choose the real default target.
-! ALL=all.cross
-
- # Choose the real install target.
- INSTALL_TARGET=install-normal
-***************
-*** 565,572 ****
- # This is what to compile if making a cross-compiler.
- # Note that we can compile enquire using the cross-compiler just built,
- # although we can't run it on this machine.
-! all.cross: native gcc-cross specs stmp-headers $(LIBGCC) $(STMP_FIXPROTO) \
-! $(CROSS_TEST) $(ENQUIRE) $(EXTRA_PARTS) lang.all.cross
- # This is what to compile if making gcc with a cross-compiler.
- all.build: native xgcc $(EXTRA_PARTS) lang.all.build
- # This is what must be made before installing GCC and converting libraries.
---- 565,571 ----
- # This is what to compile if making a cross-compiler.
- # Note that we can compile enquire using the cross-compiler just built,
- # although we can't run it on this machine.
-! all.cross: native gcc-cross specs stmp-headers
- # This is what to compile if making gcc with a cross-compiler.
- all.build: native xgcc $(EXTRA_PARTS) lang.all.build
- # This is what must be made before installing GCC and converting libraries.
-***************
-*** 692,698 ****
- # This rule deliberately does not depend on libgcc1.a
- # so that it will fail if the installer hasn't provided it.
- libgcc1.cross:
-! mv libgcc1.a libgcc1.cross || (echo You must find a way to make libgcc1.a; false)
-
- # Compile the library of arithmetic subroutines with the native compiler.
- # Don't compile it with GCC!
---- 692,698 ----
- # This rule deliberately does not depend on libgcc1.a
- # so that it will fail if the installer hasn't provided it.
- libgcc1.cross:
-! echo $@ is not implemented yet; exit 99
-
- # Compile the library of arithmetic subroutines with the native compiler.
- # Don't compile it with GCC!
-***************
-*** 1870,1877 ****
- install: $(INSTALL_TARGET) ; @true
-
- # Copy the compiler files into directories where they will be run.
-! install-normal: install-common $(INSTALL_HEADERS) $(INSTALL_LIBGCC) \
-! install-man install-info lang.install-normal
-
- # Do nothing while making gcc with a cross-compiler. The person who
- # makes gcc for the target machine has to know how to put a complete
---- 1869,1875 ----
- install: $(INSTALL_TARGET) ; @true
-
- # Copy the compiler files into directories where they will be run.
-! install-normal: install-common $(INSTALL_HEADERS) lang.install-normal
-
- # Do nothing while making gcc with a cross-compiler. The person who
- # makes gcc for the target machine has to know how to put a complete
-*** gcc-2.6.3/cccp.c~ Fri Sep 1 10:42:15 1995
---- gcc-2.6.3/cccp.c Fri Sep 1 10:42:31 1995
-***************
-*** 188,194 ****
- #ifndef VMS
- #ifndef HAVE_STRERROR
- extern int sys_nerr;
-! #if defined(bsd4_4) || defined(__NetBSD__)
- extern const char *const sys_errlist[];
- #else
- extern char *sys_errlist[];
---- 188,194 ----
- #ifndef VMS
- #ifndef HAVE_STRERROR
- extern int sys_nerr;
-! #if defined(bsd4_4) || defined(__NetBSD__) || defined(__FreeBSD__)
- extern const char *const sys_errlist[];
- #else
- extern char *sys_errlist[];
-*** gcc-2.6.3/gcc.c~ Fri Sep 1 10:57:20 1995
---- gcc-2.6.3/gcc.c Fri Sep 1 10:57:36 1995
-***************
-*** 166,172 ****
- #endif
-
- extern int sys_nerr;
-! #if defined(bsd4_4) || defined(__NetBSD__)
- extern const char *const sys_errlist[];
- #else
- extern char *sys_errlist[];
---- 166,172 ----
- #endif
-
- extern int sys_nerr;
-! #if defined(bsd4_4) || defined(__NetBSD__) || defined(__FreeBSD__)
- extern const char *const sys_errlist[];
- #else
- extern char *sys_errlist[];
diff --git a/devel/m6811-gcc/files/patch-ac b/devel/m6811-gcc/files/patch-ac
deleted file mode 100644
index e05b3f5b599d..000000000000
--- a/devel/m6811-gcc/files/patch-ac
+++ /dev/null
@@ -1,82 +0,0 @@
-*** gcc-6811-release/sample/Makefile~ Fri Sep 1 16:01:06 1995
---- gcc-6811-release/sample/Makefile Fri Sep 1 16:01:45 1995
-***************
-*** 9,15 ****
- #
- CPP=./cpp
- AR=
-! AS=/usr/local/gnu6811/bin/as6811
- # CC=cc
-! CC=/usr/local/gnu6811/bin/m6811-local-gcc
- SHELL=/bin/sh
---- 9,15 ----
- #
- CPP=./cpp
- AR=
-! AS=../xasm/asm-src/as6811
- # CC=cc
-! CC=/usr/local/bin/m6811-local-gcc
- SHELL=/bin/sh
-***************
-*** 32,34 ****
---- 32,36 ----
- clean:
- rm -f $(TARGETS) *.lst
-
-+ install:
-+ cp ${TARGETS} ${SRC} gcb11.inc ${PREFIX}/lib/gcc-lib/m6811-local/2.6.3
-*** gcc-6811-release/xasm/asm-src/Makefile~ Fri Sep 1 16:39:12 1995
---- gcc-6811-release/xasm/asm-src/Makefile Fri Sep 1 16:39:58 1995
-***************
-*** 9,15 ****
- COMMON_OBJ= asmain.o aslex.o assym.o assubr.o asexpr.o \
- asdata.o aslist.o asout.o
-
-! all: as6800 as6801 as6804 as6805 as6809 as6801 as6811 asz80 asi85
-
- clean:
- rm *.o
---- 9,19 ----
- COMMON_OBJ= asmain.o aslex.o assym.o assubr.o asexpr.o \
- asdata.o aslist.o asout.o
-
-! PRGS=as6800 as6801 as6804 as6805 as6809 as6801 as6811 asz80 asi85
-! all: ${PRGS}
-!
-! install: ${PRGS}
-! cp ${PRGS} ${PREFIX}/bin
-
- clean:
- rm *.o
-*** gcc-6811-release/xasm/lnk-src/Makefile~ Fri Sep 1 16:42:23 1995
---- gcc-6811-release/xasm/lnk-src/Makefile Fri Sep 1 16:42:44 1995
-***************
-*** 11,15 ****
---- 11,18 ----
- aslink: $(LINK_OBJ) aslink.h
- $(CC) -o aslink $(LINK_OBJ)
-
-+ install:
-+ cp aslink ${PREFIX}/bin
-+
- clean:
- rm -f aslink *.o
-*** gcc-6811-release/sample/crt0.s~ Tue Sep 5 09:09:28 1995
---- gcc-6811-release/sample/crt0.s Tue Sep 5 09:09:48 1995
-***************
-*** 377,383 ****
- ; end crt0.s
- ;
- ; .include "gios.s"
-! .include "utldbg.s"
- ; .include "malloc.s"
- ;-----------------------------------------
- ; start use code
---- 377,383 ----
- ; end crt0.s
- ;
- ; .include "gios.s"
-! ; .include "utldbg.s"
- ; .include "malloc.s"
- ;-----------------------------------------
- ; start use code
diff --git a/devel/m6811-gcc/files/patch-ad b/devel/m6811-gcc/files/patch-ad
deleted file mode 100644
index 454972e60e82..000000000000
--- a/devel/m6811-gcc/files/patch-ad
+++ /dev/null
@@ -1,7 +0,0 @@
---- gcc-2.6.3/config/i386/x-freebsd~ Mon Aug 12 10:22:41 1996
-+++ gcc-2.6.3/config/i386/x-freebsd Mon Aug 12 10:22:56 1996
-@@ -1,3 +1,3 @@
- # Don't run fixproto
- STMP_FIXPROTO =
--CLIB=-lgnumalloc
-+CLIB=