aboutsummaryrefslogtreecommitdiff
path: root/devel/mcpp/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/mcpp/Makefile')
-rw-r--r--devel/mcpp/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/devel/mcpp/Makefile b/devel/mcpp/Makefile
new file mode 100644
index 000000000000..e203148ee1f2
--- /dev/null
+++ b/devel/mcpp/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: mcpp
+# Date created: 06 April 2007
+# Whom: Kiyoshi Matsui <kmatsui@t3.rim.or.jp>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mcpp
+PORTVERSION= 2.6.3
+CATEGORIES= devel
+MASTER_SITES= http://prdownloads.sourceforge.net/mcpp/ \
+ http://jaist.dl.sourceforge.net/sourceforge/mcpp/
+
+MAINTAINER= kmatsui@t3.rim.or.jp
+COMMENT= Alternative C/C++ preprocessor
+
+GNU_CONFIGURE= yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+MAN1= mcpp.1
+
+PLIST_FILES= bin/mcpp \
+ share/doc/mcpp/LICENSE \
+ share/doc/mcpp/NEWS \
+ share/doc/mcpp/README \
+ share/doc/mcpp/doc-jp/mcpp-manual.html \
+ share/doc/mcpp/doc/mcpp-manual.html
+PLIST_DIRS= share/doc/mcpp/doc-jp \
+ share/doc/mcpp/doc \
+ share/doc/mcpp
+
+.include <bsd.port.mk>