aboutsummaryrefslogtreecommitdiff
path: root/devel/mcpp
diff options
context:
space:
mode:
Diffstat (limited to 'devel/mcpp')
-rw-r--r--devel/mcpp/Makefile1
-rw-r--r--devel/mcpp/files/patch-system.h25
2 files changed, 26 insertions, 0 deletions
diff --git a/devel/mcpp/Makefile b/devel/mcpp/Makefile
index 91f58f302d83..c363f9672a5e 100644
--- a/devel/mcpp/Makefile
+++ b/devel/mcpp/Makefile
@@ -7,6 +7,7 @@
PORTNAME= mcpp
PORTVERSION= 2.6.4
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= http://prdownloads.sourceforge.net/mcpp/ \
http://jaist.dl.sourceforge.net/sourceforge/mcpp/
diff --git a/devel/mcpp/files/patch-system.h b/devel/mcpp/files/patch-system.h
new file mode 100644
index 000000000000..f8508f018ebc
--- /dev/null
+++ b/devel/mcpp/files/patch-system.h
@@ -0,0 +1,25 @@
+Place this text as ports/devel/mcpp/files/patch-src-system.H.
+I copy and paste the file here, since attaching file does not work somehow.
+TABs are lost in this. Please en-tab in the first two tag-lines.
+
+--- src/system.H.orig Wed May 2 21:37:29 2007
++++ src/system.H Sun Jun 3 16:51:33 2007
+@@ -49,7 +49,16 @@
+
+ /* Some system has a wrong definition of UCHAR_MAX. See cpp-test.html#5.1.3 */
+ #if UCHARMAX < -255
++#if __FreeBSD__
++/*
++ * This is a temporary patch for FreeBSD on amd64, alpha, ia64 and sparc64.
++ * limits.h of these systems wrongly define UCHAR_MAX as 255U.
++ */
++#undef UCHARMAX
++#define UCHARMAX 255
++#else
+ #error "The definition of UCHARMAX (possibly UCHAR_MAX too) is wrong. Define it as signed int value as 255, not as unsigned value as 255U."
++#endif
+ #endif
+
+ /*
+
+