aboutsummaryrefslogtreecommitdiff
path: root/devel/mico
diff options
context:
space:
mode:
Diffstat (limited to 'devel/mico')
-rw-r--r--devel/mico/Makefile19
-rw-r--r--devel/mico/files/patch-orb-ssl.cc13
2 files changed, 18 insertions, 14 deletions
diff --git a/devel/mico/Makefile b/devel/mico/Makefile
index 358093fd186e..14756edb300e 100644
--- a/devel/mico/Makefile
+++ b/devel/mico/Makefile
@@ -7,6 +7,7 @@
PORTNAME= mico
PORTVERSION= 2.3.12
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= http://www.mico.org/
@@ -16,15 +17,14 @@ PATCHFILES= mico-2.3.12-secfix1.diff
MAINTAINER= sem@FreeBSD.org
COMMENT= Secure, reliable, production-quality, standards-based CORBA middleware
-PATCH_DIST_STRIP=-p1
+PATCH_DIST_STRIP= -p1
WRKSRC= ${WRKDIR}/${PORTNAME}
INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
USE_GMAKE= yes
-USE_AUTOTOOLS= autoconf:259
+USE_AUTOTOOLS= autoconf:259
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-#CONFIGURE_ENV+= CC=${CC} CFLAGS="${CFLAGS}" CXX=${CXX} \
-# CXXFLAGS="${CXXFLAGS}" CPP=${CPP}
+CONFIGURE_ENV+= EGREP=`which egrep`
OPTIONS= NOSERVICES "Without services, plain ORB" off \
SSL "Build with SSL" on \
@@ -45,7 +45,7 @@ OPTIONSFILE?= ${PORT_DBDIR}/${PORTNAME}/options
.endif
# ================
-USE_GCC= 3.4
+USE_GCC= 3.4+
CONFIGURE_ARGS= --enable-cd --disable-mini-stl --enable-threads
@@ -108,15 +108,6 @@ MAN8= ird.8 micod.8 nsd.8
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 700019
-BROKEN= Does not compile on FreeBSD >= 7.0
-.endif
-
-# Does not build on alpha 4.x
-.if ${OSVERSION} < 500000
-NOT_FOR_ARCHS= alpha
-.endif
-
post-patch:
@${REINPLACE_CMD} -e "s#\"-O2\"#\"${CFLAGS}\"#;s#\"-pthread#\"${PTHREAD_LIBS}#" ${WRKSRC}/configure.in
.if ${OSVERSION} < 500035
diff --git a/devel/mico/files/patch-orb-ssl.cc b/devel/mico/files/patch-orb-ssl.cc
new file mode 100644
index 000000000000..615d299088c0
--- /dev/null
+++ b/devel/mico/files/patch-orb-ssl.cc
@@ -0,0 +1,13 @@
+--- orb/ssl.cc.orig Sun Sep 17 01:11:12 2006
++++ orb/ssl.cc Sun Sep 17 01:11:36 2006
+@@ -800,9 +800,7 @@
+ if (!fp)
+ return NULL;
+
+- x509 = (X509 *)PEM_ASN1_read ((char *(*)())d2i_X509,
+- PEM_STRING_X509,
+- fp, NULL, NULL,NULL);
++ x509 = PEM_read_X509 (fp, NULL, NULL,NULL);
+
+ if (x509 == NULL) {
+ //ERR_print_errors_fp (stderr);