aboutsummaryrefslogtreecommitdiff
path: root/devel/mongo-cxx-driver
diff options
context:
space:
mode:
Diffstat (limited to 'devel/mongo-cxx-driver')
-rw-r--r--devel/mongo-cxx-driver/Makefile30
-rw-r--r--devel/mongo-cxx-driver/distinfo2
-rw-r--r--devel/mongo-cxx-driver/files/patch-SConstruct33
-rw-r--r--devel/mongo-cxx-driver/pkg-descr7
-rw-r--r--devel/mongo-cxx-driver/pkg-plist112
5 files changed, 184 insertions, 0 deletions
diff --git a/devel/mongo-cxx-driver/Makefile b/devel/mongo-cxx-driver/Makefile
new file mode 100644
index 000000000000..dfcd67596e96
--- /dev/null
+++ b/devel/mongo-cxx-driver/Makefile
@@ -0,0 +1,30 @@
+# Created by: Simun Mikecin <numisemis@yahoo.com>
+# $FreeBSD$
+
+PORTNAME= mongo-cxx-driver
+PORTVERSION= 1.0.5
+DISTVERSIONPREFIX=v
+CATEGORIES= devel
+
+MAINTAINER= numisemis@yahoo.com
+COMMENT= C++ Driver for MongoDB
+
+LICENSE= APACHE20
+
+LIB_DEPENDS= libboost_system.so:${PORTSDIR}/devel/boost-libs
+
+MAKE_JOBS_UNSAFE= yes
+
+USE_GITHUB= yes
+GH_ACCOUNT= mongodb
+GH_PROJECT= mongo-cxx-driver
+GH_TAGNAME= e849f94
+
+WRKSRC= ${WRKDIR}/mongo-cxx-driver-e849f94
+USES= execinfo scons
+MAKE_ARGS= --prefix=${STAGEDIR}${PREFIX} \
+ --cc=${CC} \
+ --cxx=${CXX}
+USE_LDCONFIG= yes
+
+.include <bsd.port.mk>
diff --git a/devel/mongo-cxx-driver/distinfo b/devel/mongo-cxx-driver/distinfo
new file mode 100644
index 000000000000..3b10b2f52a9b
--- /dev/null
+++ b/devel/mongo-cxx-driver/distinfo
@@ -0,0 +1,2 @@
+SHA256 (mongodb-mongo-cxx-driver-v1.0.5-e849f94_GH0.tar.gz) = f3db90b238e89f3327efe675405b6446037ebf6a055094f71d190c582b19fdd1
+SIZE (mongodb-mongo-cxx-driver-v1.0.5-e849f94_GH0.tar.gz) = 1573851
diff --git a/devel/mongo-cxx-driver/files/patch-SConstruct b/devel/mongo-cxx-driver/files/patch-SConstruct
new file mode 100644
index 000000000000..6b694d2724e5
--- /dev/null
+++ b/devel/mongo-cxx-driver/files/patch-SConstruct
@@ -0,0 +1,33 @@
+--- SConstruct.orig 2015-08-18 15:46:59 UTC
++++ SConstruct
+@@ -354,6 +354,30 @@ env_vars.Add('SHLINKFLAGS',
+ help='Sets flags for the linker when building shared libraries',
+ converter=variable_shlex_converter)
+
++env_vars.Add('CXX',
++ help='Sets path to the C++ compiler',
++ converter=variable_shlex_converter)
++
++env_vars.Add('CC',
++ help='Sets path to the C compiler',
++ converter=variable_shlex_converter)
++
++env_vars.Add('PREFIX',
++ help='Sets PREFIX path',
++ converter=variable_shlex_converter)
++
++env_vars.Add('PKGCONFIGDIR',
++ help='Sets PKGCONFIGDIR path',
++ converter=variable_shlex_converter)
++
++env_vars.Add('destdir',
++ help='Sets destdir path',
++ converter=variable_shlex_converter)
++
++env_vars.Add('DESTDIR',
++ help='Sets DESTDIR path',
++ converter=variable_shlex_converter)
++
+ # don't run configure if user calls --help
+ if GetOption('help'):
+ Return()
diff --git a/devel/mongo-cxx-driver/pkg-descr b/devel/mongo-cxx-driver/pkg-descr
new file mode 100644
index 000000000000..4f50a78f7e9f
--- /dev/null
+++ b/devel/mongo-cxx-driver/pkg-descr
@@ -0,0 +1,7 @@
+Official Mongo C++ Driver
+
+Mongo (from "humongous") is a high-performance, open source,
+schema-free, document-oriented database. A common name in the
+"NOSQL" community.
+
+WWW: https://github.com/mongodb/mongo-cxx-driver
diff --git a/devel/mongo-cxx-driver/pkg-plist b/devel/mongo-cxx-driver/pkg-plist
new file mode 100644
index 000000000000..7e2f87c89c8e
--- /dev/null
+++ b/devel/mongo-cxx-driver/pkg-plist
@@ -0,0 +1,112 @@
+include/mongo/base/data_cursor.h
+include/mongo/base/data_view.h
+include/mongo/base/disallow_copying.h
+include/mongo/base/encoded_value_storage.h
+include/mongo/base/error_codes.h
+include/mongo/base/parse_number.h
+include/mongo/base/status-inl.h
+include/mongo/base/status.h
+include/mongo/base/status_with.h
+include/mongo/base/string_data-inl.h
+include/mongo/base/string_data.h
+include/mongo/bson/bson-inl.h
+include/mongo/bson/bson.h
+include/mongo/bson/bson_db.h
+include/mongo/bson/bson_field.h
+include/mongo/bson/bson_validate.h
+include/mongo/bson/bsonelement.h
+include/mongo/bson/bsonmisc.h
+include/mongo/bson/bsonobj.h
+include/mongo/bson/bsonobjbuilder.h
+include/mongo/bson/bsonobjiterator.h
+include/mongo/bson/bsontypes.h
+include/mongo/bson/inline_decls.h
+include/mongo/bson/oid.h
+include/mongo/bson/ordering.h
+include/mongo/bson/timestamp.h
+include/mongo/bson/util/builder.h
+include/mongo/client/autolib.h
+include/mongo/client/bulk_operation_builder.h
+include/mongo/client/bulk_update_builder.h
+include/mongo/client/bulk_upsert_builder.h
+include/mongo/client/dbclient.h
+include/mongo/client/dbclient_rs.h
+include/mongo/client/dbclientcursor.h
+include/mongo/client/dbclientinterface.h
+include/mongo/client/exceptions.h
+include/mongo/client/export_macros.h
+include/mongo/client/gridfs.h
+include/mongo/client/index_spec.h
+include/mongo/client/init.h
+include/mongo/client/options.h
+include/mongo/client/redef_macros.h
+include/mongo/client/sasl_client_authenticate.h
+include/mongo/client/undef_macros.h
+include/mongo/client/write_concern.h
+include/mongo/client/write_options.h
+include/mongo/client/write_result.h
+include/mongo/config.h
+include/mongo/db/jsobj.h
+include/mongo/db/json.h
+include/mongo/geo/boundingbox.h
+include/mongo/geo/constants.h
+include/mongo/geo/coordinates.h
+include/mongo/geo/coordinates2d.h
+include/mongo/geo/coordinates2dgeographic.h
+include/mongo/geo/geometry.h
+include/mongo/geo/geometrycollection.h
+include/mongo/geo/geoobj.h
+include/mongo/geo/interface.h
+include/mongo/geo/linestring.h
+include/mongo/geo/multilinestring.h
+include/mongo/geo/multipoint.h
+include/mongo/geo/multipolygon.h
+include/mongo/geo/namespaces.h
+include/mongo/geo/parser-impl.h
+include/mongo/geo/parser.h
+include/mongo/geo/point.h
+include/mongo/geo/polygon.h
+include/mongo/geo/queryutils.h
+include/mongo/logger/appender.h
+include/mongo/logger/component_message_log_domain.h
+include/mongo/logger/labeled_level.h
+include/mongo/logger/log_component.h
+include/mongo/logger/log_component_settings.h
+include/mongo/logger/log_domain.h
+include/mongo/logger/log_manager.h
+include/mongo/logger/log_severity-inl.h
+include/mongo/logger/log_severity.h
+include/mongo/logger/logger.h
+include/mongo/logger/logstream_builder.h
+include/mongo/logger/message_event.h
+include/mongo/logger/message_log_domain.h
+include/mongo/platform/atomic_intrinsics.h
+include/mongo/platform/atomic_intrinsics_gcc_atomic.h
+include/mongo/platform/atomic_intrinsics_gcc_intel.h
+include/mongo/platform/atomic_intrinsics_gcc_sync.h
+include/mongo/platform/atomic_intrinsics_win32.h
+include/mongo/platform/atomic_word.h
+include/mongo/platform/atomic_word_cxx11.h
+include/mongo/platform/atomic_word_intrinsics.h
+include/mongo/platform/compiler.h
+include/mongo/platform/compiler_gcc.h
+include/mongo/platform/compiler_msvc.h
+include/mongo/platform/cstdint.h
+include/mongo/platform/endian.h
+include/mongo/platform/float_utils.h
+include/mongo/platform/hash_namespace.h
+include/mongo/platform/strnlen.h
+include/mongo/platform/unordered_map.h
+include/mongo/platform/windows_basic.h
+include/mongo/stdx/functional.h
+include/mongo/util/assert_util.h
+include/mongo/util/mongoutils/str.h
+include/mongo/util/net/hostandport.h
+include/mongo/util/net/message.h
+include/mongo/util/net/message_port.h
+include/mongo/util/net/operation.h
+include/mongo/util/net/sock.h
+include/mongo/util/shared_buffer.h
+include/mongo/util/time_support.h
+include/mongo/version.h
+lib/libmongoclient.a