aboutsummaryrefslogtreecommitdiff
path: root/devel/ocaml-camomile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/ocaml-camomile')
-rw-r--r--devel/ocaml-camomile/Makefile9
-rw-r--r--devel/ocaml-camomile/distinfo6
-rw-r--r--devel/ocaml-camomile/files/patch-Makefile.in24
3 files changed, 22 insertions, 17 deletions
diff --git a/devel/ocaml-camomile/Makefile b/devel/ocaml-camomile/Makefile
index e618963b91ba..6f9cbaf422e7 100644
--- a/devel/ocaml-camomile/Makefile
+++ b/devel/ocaml-camomile/Makefile
@@ -7,8 +7,7 @@
#
PORTNAME= camomile
-PORTVERSION= 0.6.6
-PORTREVISION= 1
+PORTVERSION= 0.7.1
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -28,6 +27,9 @@ GNU_CONFIGURE= yes
DOCSDIR= ${PREFIX}/share/doc/ocaml/${PORTNAME}
EXAMPLESDIR= ${PREFIX}/share/examples/ocaml/${PORTNAME}
+PLIST_FILES= bin/camomilecharmap \
+ bin/camomilelocaledef
+
.include <bsd.port.pre.mk>
.include "${PORTSDIR}/lang/ocaml/bsd.ocaml.mk"
@@ -35,8 +37,7 @@ EXAMPLESDIR= ${PREFIX}/share/examples/ocaml/${PORTNAME}
BROKEN= Need working <wctype.h>
.endif
-post-extract:
- @${CP} ${WRKSRC}/META ${WRKSRC}/META.in
+post-patch:
@${REINPLACE_CMD} -E -e \
"s,([[:space:]]*)cp[[:space:]]*-f,\1\$${BSD_INSTALL_DATA}," \
${WRKSRC}/Makefile.in
diff --git a/devel/ocaml-camomile/distinfo b/devel/ocaml-camomile/distinfo
index 368abe6b64e4..9d3b630c5402 100644
--- a/devel/ocaml-camomile/distinfo
+++ b/devel/ocaml-camomile/distinfo
@@ -1,3 +1,3 @@
-MD5 (camomile-0.6.6.tar.bz2) = 3b4f19bc172189c17254e74abaa9644c
-SHA256 (camomile-0.6.6.tar.bz2) = 1de5d220dedc5684117aee4d7372e82358f01134bef131c8aeb1d25240d1c23f
-SIZE (camomile-0.6.6.tar.bz2) = 2124681
+MD5 (camomile-0.7.1.tar.bz2) = 9b8cedcf91e9795f85aaade5a6f1c515
+SHA256 (camomile-0.7.1.tar.bz2) = 9103ff245ab8265e5bdbb2cfa1028ab5ea06b660bf59ecb4c3fd6ae4ad523e9f
+SIZE (camomile-0.7.1.tar.bz2) = 2133102
diff --git a/devel/ocaml-camomile/files/patch-Makefile.in b/devel/ocaml-camomile/files/patch-Makefile.in
index f108a36512e7..19dde04ca01b 100644
--- a/devel/ocaml-camomile/files/patch-Makefile.in
+++ b/devel/ocaml-camomile/files/patch-Makefile.in
@@ -1,11 +1,15 @@
---- Makefile.in.orig Tue Aug 1 16:47:03 2006
-+++ Makefile.in Tue Aug 1 16:47:47 2006
-@@ -378,7 +378,7 @@
+--- Makefile.in.orig Tue Aug 22 13:35:58 2006
++++ Makefile.in Tue Aug 22 13:36:45 2006
+@@ -375,8 +375,10 @@
+ ocamlfind install camomile $$files META $(MLI) camomileLibrary.cmi
- install-with-ocamlfind:
- files= &&\
-- if [ $(OCAMLBEST) = opt ]; then files=public/*.cmx; fi && \
-+ if [ "$(OCAMLBEST)" = "opt" ]; then files=public/*.cmx; fi && \
- if [ -f camomile.cma ]; then files="camomile.* $$files"; fi&& \
- if [ -f libcamomile.a ]; then files="libcamomile.a $$files"; fi && \
- if [ -f dllcamomile.so ]; then files="dllcamomile.so $$files"; fi && \
+ install-bin:
+- cp -f tools/camomilecharmap.$(OCAMLBEST) $(BINDIR)
+- cp -f tools/camomilelocaledef.$(OCAMLBEST) $(BINDIR)
++ ${BSD_INSTALL_PROGRAM} tools/camomilecharmap.$(OCAMLBEST) \
++ $(BINDIR)/camomilecharmap
++ ${BSD_INSTALL_PROGRAM} tools/camomilelocaledef.$(OCAMLBEST) \
++ $(BINDIR)/camomilelocaledef
+
+ install-data:
+ mkdir -p $(DATADIR)