aboutsummaryrefslogtreecommitdiff
path: root/devel/ocaml-lacaml/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/ocaml-lacaml/Makefile')
-rw-r--r--devel/ocaml-lacaml/Makefile12
1 files changed, 9 insertions, 3 deletions
diff --git a/devel/ocaml-lacaml/Makefile b/devel/ocaml-lacaml/Makefile
index b339f2bbd233..eed120ffe458 100644
--- a/devel/ocaml-lacaml/Makefile
+++ b/devel/ocaml-lacaml/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= lacaml
-PORTVERSION= 7.1.5
+PORTVERSION= 7.2.6
DISTVERSIONPREFIX= v
CATEGORIES= devel
PKGNAMEPREFIX= ocaml-
@@ -26,11 +26,11 @@ USES= blaslapack fortran
HAS_CONFIGURE= yes
CONFIGURE_ARGS= --prefix ${PREFIX} --disable-docs --disable-examples \
--override conf_ccopt "${CFLAGS}" \
- --override conf_cclib "${LDFLAGS:S,^.*[[:space:]],,}"
+ --override conf_cclib "${LDFLAGS}"
MAKE_JOBS_UNSAFE=yes
CFLAGS+= -fPIC -DEXTERNAL_EXP10
-LDFLAGS+= -L${LOCALBASE}/lib ${BLASLIB} ${LAPACKLIB}
+LDFLAGS+= -L${LOCALBASE}/lib
DOCSDIR= ${OCAML_DOCSDIR}/${PORTNAME}
EXAMPLESDIR= ${OCAML_EXAMPLESDIR}/${PORTNAME}
@@ -40,6 +40,12 @@ PORTEXAMPLES= *
OPTIONS_DEFINE= DOCS EXAMPLES
+post-patch:
+ @${REINPLACE_CMD} -e \
+ 's|%%BLASLIB%%|${BLASLIB}| ; \
+ s|%%LAPACKLIB%%|${LAPACKLIB}| ; \
+ s|%%LOCALBASE%%|${LOCALBASE}|' ${WRKSRC}/myocamlbuild.ml
+
post-install:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
.for i in AUTHORS.txt CHANGES.txt README.md TODO.md