aboutsummaryrefslogtreecommitdiff
path: root/devel/ocaml-xstr/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/ocaml-xstr/Makefile')
-rw-r--r--devel/ocaml-xstr/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/devel/ocaml-xstr/Makefile b/devel/ocaml-xstr/Makefile
new file mode 100644
index 000000000000..6b35c17ae54a
--- /dev/null
+++ b/devel/ocaml-xstr/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: ocaml-xstr
+# Date created: 2006-07-29
+# Whom: Stanislav Sedov <ssedov@mbsd.msk.ru>
+#
+# $MBSDlabs$
+# $FreeBSD$
+#
+
+PORTNAME= xstr
+PORTVERSION= 0.2.1
+CATEGORIES= devel
+MASTER_SITES= http://www.ocaml-programming.de/packages/
+PKGNAMEPREFIX= ocaml-
+
+MAINTAINER= ssedov@mbsd.msk.ru
+COMMENT= Thread-safe implementation of string searching/matching
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+USE_GMAKE= yes
+USE_OCAML= yes
+USE_OCAML_FINDLIB=yes
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/lang/ocaml/bsd.ocaml.mk"
+.include <bsd.port.post.mk>