aboutsummaryrefslogtreecommitdiff
path: root/devel/ode-devel/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/ode-devel/Makefile')
-rw-r--r--devel/ode-devel/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/devel/ode-devel/Makefile b/devel/ode-devel/Makefile
index fea4c845bb87..2a68234a3232 100644
--- a/devel/ode-devel/Makefile
+++ b/devel/ode-devel/Makefile
@@ -20,6 +20,12 @@ USE_GL= yes
USE_GMAKE= yes
USE_REINPLACE= yes
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "amd64"
+BROKEN= "Does not build on amd64"
+.endif
+
post-patch:
@${REINPLACE_CMD} -e \
's|malloc.h|stdlib.h|g' \
@@ -47,4 +53,4 @@ do-install:
@${MKDIR} ${PREFIX}/include/ode
@${INSTALL_DATA} ${WRKSRC}/include/ode/*.h ${PREFIX}/include/ode
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>