aboutsummaryrefslogtreecommitdiff
path: root/devel/oniguruma/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/oniguruma/Makefile')
-rw-r--r--devel/oniguruma/Makefile10
1 files changed, 7 insertions, 3 deletions
diff --git a/devel/oniguruma/Makefile b/devel/oniguruma/Makefile
index 87caf91c066c..ed28a9ae35e9 100644
--- a/devel/oniguruma/Makefile
+++ b/devel/oniguruma/Makefile
@@ -6,10 +6,9 @@
#
PORTNAME= oniguruma
-PORTVERSION= 2.3.1
+PORTVERSION= 2.5.0
CATEGORIES= devel
-MASTER_SITES= ${MASTER_SITE_LOCAL}
-MASTER_SITE_SUBDIR= fenner/ruby-contrib
+MASTER_SITES= http://www.geocities.jp/kosako3/oniguruma/archive/
DISTNAME= onigd${PORTVERSION:S/./_/g}
DIST_SUBDIR= ruby
@@ -19,9 +18,14 @@ COMMENT= A BSDL Regular Expressions library compatible with POSIX/GNU/Perl
WRKSRC= ${WRKDIR}/${PORTNAME}
GNU_CONFIGURE= yes
#INSTALLS_SHLIB= yes
+USE_REINPLACE= yes
DOCS= HISTORY README doc/*
+# Use patch for ruby 1.8.2 rather than 1.8.3
+post-patch:
+ ${REINPLACE_CMD} 's,18: 183,18: 182,' ${WRKSRC}/Makefile.in
+
post-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${EXAMPLESDIR}