aboutsummaryrefslogtreecommitdiff
path: root/devel/p4web
diff options
context:
space:
mode:
Diffstat (limited to 'devel/p4web')
-rw-r--r--devel/p4web/Makefile127
-rw-r--r--devel/p4web/distinfo.alpha6
-rw-r--r--devel/p4web/distinfo.i38615
-rw-r--r--devel/p4web/files/perforce.conf.in75
-rw-r--r--devel/p4web/files/perforce.sh.in61
-rw-r--r--devel/p4web/pkg-descr4
-rw-r--r--devel/p4web/pkg-install51
-rw-r--r--devel/p4web/pkg-plist4
8 files changed, 0 insertions, 343 deletions
diff --git a/devel/p4web/Makefile b/devel/p4web/Makefile
deleted file mode 100644
index 2995c3efca3c..000000000000
--- a/devel/p4web/Makefile
+++ /dev/null
@@ -1,127 +0,0 @@
-# New ports collection makefile for: perforce
-# Date created: 3 Mai 2000
-# Whom: sam@inf.enst.fr
-#
-# $FreeBSD$
-#
-
-PORTNAME= perforce
-PORTVERSION= ${VERSION}
-PORTREVISION= ${REVISION}
-PORTEPOCH= 1
-CATEGORIES= devel
-MASTER_SITES= ftp://ftp.perforce.com/pub/perforce/r${PORTVERSION}/bin.${PLATFORM}/
-EXTRACT_SUFX=
-DISTFILES= ${BIN_FILES} ${SBIN_FILES}
-EXTRACT_ONLY= # none
-
-MAINTAINER= lth@FreeBSD.org
-COMMENT= Perforce client and server
-
-#
-# This is a kludge. I don't know a better way to set PORTVERSION and
-# PORTREVISION such that pkg_version figures out an update is needed
-#
-ARCH!= /usr/bin/uname -p
-ARCH?= i386
-
-.if (${ARCH} == i386) || (${ARCH} == amd64)
-DIST_SUBDIR= perforce/${VERSION}/i386
-VERSION= 05.2
-REVISION= 2
-PLATFORM= freebsd4
-BIN_FILES= p4
-SBIN_FILES= p4d p4ftpd p4p p4web
-REL_NOTES= http://www.perforce.com/perforce/doc.052/user/relnotes.txt
-MD5_FILE= ${MASTERDIR}/distinfo.i386
-.elif ${ARCH} == alpha
-DIST_SUBDIR= perforce/${VERSION}/${ARCH}
-VERSION= 99.1
-REVISION= 1
-PLATFORM= freebsdaxp
-BIN_FILES= p4
-SBIN_FILES= p4d
-REL_NOTES= http://www.perforce.com/perforce/doc.991/user/relnotes.txt
-MD5_FILE= ${MASTERDIR}/distinfo.${ARCH}
-.else
-VERSION= 0
-IGNORE= "Unsupported platform, sorry."
-.endif
-
-# End of kludge
-
-NO_PACKAGE= Restricted distribution
-NO_CDROM= Restricted distribution
-
-NO_WRKSUBDIR= yes
-
-PLIST_FILES= ${BIN_FILES:S+^+bin/+g} \
- ${SBIN_FILES:S+^+sbin/+g}
-
-.include <bsd.port.pre.mk>
-
-# These variables are all configurable.
-PERFORCE_USER?= p4admin
-PERFORCE_UID?= 94
-PERFORCE_GROUP?= p4admin
-PERFORCE_GID?= 94
-PERFORCE_HOME?= ${LOCALBASE}/perforce
-PERFORCE_ROOT?= ${PERFORCE_HOME}/root
-PERFORCE_LOGS?= ${PERFORCE_HOME}/logs
-PERFORCE_PORT?= 1666
-PERFORCE_CACHE?= ${PERFORCE_HOME}/cache
-PERFORCE_TARGET?= perforce:1666
-
-pre-everything::
- @${ECHO} "If the checksums fail, try doing 'make distclean'"
- @${ECHO} "to force getting the latest binaries from Perforce."
- @${ECHO} ""
- @${ECHO} "Read the release notes for this release to determine"
- @${ECHO} "how to migrate the database to the new version. In"
- @${ECHO} "most instances, it is done automatically. However,"
- @${ECHO} "sometimes it must be done manually."
- @${ECHO} ""
- @${ECHO} "The release notes for this version are at"
- @${ECHO} ${REL_NOTES}
- @${ECHO} ""
- @${ECHO} "Checkpoint and backup your data before installing!"
-
-do-build:
- ${SED} -e "s,@PERFORCE_ROOT@,${PERFORCE_ROOT},g" \
- -e "s,@PERFORCE_LOGS@,${PERFORCE_LOGS},g" \
- -e "s,@PERFORCE_USER@,${PERFORCE_USER},g" \
- -e "s,@PERFORCE_PORT@,${PERFORCE_PORT},g" \
- -e "s,@PERFORCE_CACHE@,${PERFORCE_CACHE},g" \
- -e "s,@PERFORCE_TARGET@,${PERFORCE_TARGET},g" \
- < ${FILESDIR}/perforce.conf.in > ${WRKSRC}/perforce.conf
- ${SED} -e "s,@PREFIX@,${PREFIX},g" \
- < ${FILESDIR}/perforce.sh.in > ${WRKSRC}/perforce.sh
-
-pre-su-install:
- ${SETENV} PKG_PREFIX=${PREFIX} \
- PERFORCE_USER=${PERFORCE_USER} \
- PERFORCE_UID=${PERFORCE_UID} \
- PERFORCE_GROUP=${PERFORCE_GROUP} \
- PERFORCE_GID=${PERFORCE_GID} \
- PERFORCE_HOME=${PERFORCE_HOME} \
- PERFORCE_ROOT=${PERFORCE_ROOT} \
- PERFORCE_LOGS=${PERFORCE_LOGS} \
- ${SH} ${PKGDIR}/pkg-install ${PORTNAME} PRE-INSTALL
-
-do-install:
-.for f in ${BIN_FILES}
- ${INSTALL_PROGRAM} ${_DISTDIR}/${f} ${PREFIX}/bin/
-.endfor
-.for f in ${SBIN_FILES}
- ${INSTALL_PROGRAM} ${_DISTDIR}/${f} ${PREFIX}/sbin/
-.endfor
- ${INSTALL_DATA} ${WRKSRC}/perforce.conf ${PREFIX}/etc/perforce.conf.default; \
- if [ ! -f ${PREFIX}/etc/perforce.conf ]; then \
- ${CP} -p ${PREFIX}/etc/perforce.conf.default ${PREFIX}/etc/perforce.conf; \
- fi
- ${INSTALL_SCRIPT} ${WRKSRC}/perforce.sh ${PREFIX}/etc/rc.d/
-
-post-install:
- ${ECHO_CMD} "@unexec ${RMDIR} ${PERFORCE_ROOT} ${PERFORCE_LOGS} ${PERFORCE_HOME} 2>/dev/null || true" >> ${TMPPLIST}
-
-.include <bsd.port.post.mk>
diff --git a/devel/p4web/distinfo.alpha b/devel/p4web/distinfo.alpha
deleted file mode 100644
index 0c6b5f2e7179..000000000000
--- a/devel/p4web/distinfo.alpha
+++ /dev/null
@@ -1,6 +0,0 @@
-MD5 (perforce/99.1/alpha/p4) = 7c1300a82ab03b7ede46cf8a02c48fd9
-MD5 (perforce/99.1/alpha/p4d) = 8f34c41c18185011ed848aaf450cffa5
-MD5 (perforce/99.1/alpha/p4.1) = 4a9d035eb5ef96342c2f701a02da40f9
-MD5 (perforce/99.1/alpha/p4d.1) = a08eb04e9668ba4d0abf47f3b12c56f7
-MD5 (perforce/03.1/i386/p4.1) = 58208eb02ba3786eed2d8e91d851cecd
-MD5 (perforce/03.1/i386/p4d.1) = 381a27c69d707aa3498602a1c216a8d3
diff --git a/devel/p4web/distinfo.i386 b/devel/p4web/distinfo.i386
deleted file mode 100644
index d4c8544b79b9..000000000000
--- a/devel/p4web/distinfo.i386
+++ /dev/null
@@ -1,15 +0,0 @@
-MD5 (perforce/05.2/i386/p4) = f096ecd881b6975dbd2149d9f12a3f90
-SHA256 (perforce/05.2/i386/p4) = fe99e70f8f790545c103219e0cb1ab2a4ac5df56bdf0cc50703669187e0f264b
-SIZE (perforce/05.2/i386/p4) = 717180
-MD5 (perforce/05.2/i386/p4d) = 1c54e08433e40bf84fad07d5471aa179
-SHA256 (perforce/05.2/i386/p4d) = 42f90437197a48934b08600863ba911c2ae7230bd0f459d496a948eb5cea200f
-SIZE (perforce/05.2/i386/p4d) = 1509624
-MD5 (perforce/05.2/i386/p4ftpd) = 83795e349b19e2260fe999eb5bd2c861
-SHA256 (perforce/05.2/i386/p4ftpd) = ba0b8b6271608e003f7db3dce6da299d47f98eca29883ad22cbb5d75fd79be29
-SIZE (perforce/05.2/i386/p4ftpd) = 831316
-MD5 (perforce/05.2/i386/p4p) = f180f17fbc926423d8ae83e6f5d9c862
-SHA256 (perforce/05.2/i386/p4p) = 27527dd4cab4f06f2c46990dafddfcaa24e98ca1f61b05c2070049ced5a1d710
-SIZE (perforce/05.2/i386/p4p) = 593760
-MD5 (perforce/05.2/i386/p4web) = 95f56027c78f829f554882e9cac697ca
-SHA256 (perforce/05.2/i386/p4web) = b8febd81d193e264d9e348ec23024e45440ea2daef54f16d4d4c68fdcfa79f26
-SIZE (perforce/05.2/i386/p4web) = 1732661
diff --git a/devel/p4web/files/perforce.conf.in b/devel/p4web/files/perforce.conf.in
deleted file mode 100644
index 803c56f86d17..000000000000
--- a/devel/p4web/files/perforce.conf.in
+++ /dev/null
@@ -1,75 +0,0 @@
-#
-# Perforce FreeBSD configuration file
-#
-#
-# $FreeBSD$
-
-#
-# Perforce ROOT
-#
-PERFORCE_ROOT="@PERFORCE_ROOT@"
-
-#
-# Perforce user (it is recommended to run p4d as a non-root user)
-#
-PERFORCE_USER="@PERFORCE_USER@"
-
-#
-# p4d/p4p port (default: 1666)
-#
-PERFORCE_PORT="@PERFORCE_PORT@"
-
-#
-# p4p cache directory
-#
-PERFORCE_PROXY_CACHE="@PERFORCE_CACHE@"
-
-#
-# p4p target server (default: perforce:1666)
-#
-PERFORCE_PROXY_TARGET="@PERFORCE_TARGET@"
-
-#
-# p4d options (see man p4d)
-#
-PERFORCE_OPTIONS="-d -p $PERFORCE_PORT -v server=1 -L @PERFORCE_LOGS@/p4d.log"
-
-#
-# Uncomment this line to have the server started automatically
-#
-#PERFORCE_START=yes
-
-#
-# p4ftpd options (see p4ftpd -h)
-#
-PERFORCE_FTPD_OPTIONS="-d -p $PERFORCE_PORT -v server=1 -L @PERFORCE_LOGS@/p4ftpd.log"
-
-#
-# Uncomment this line to have the server started automatically
-#
-#PERFORCE_FTPD_START=yes
-
-#
-# p4p options (see p4p -h)
-#
-PERFORCE_PROXY_OPTIONS="-d -p $PERFORCE_PORT -t $PERFORCE_PROXY_TARGET -r $PERFORCE_PROXY_CACHE -v server=1 -L @PERFORCE_LOGS@/p4p.log"
-
-#
-# Uncomment this line to have the proxy server started automatically
-#
-#PERFORCE_PROXY_START=yes
-
-#
-# p4web port
-#
-PERFORCE_WEB_PORT="6060"
-
-#
-# p4web options (see p4web -h)
-#
-PERFORCE_WEB_OPTIONS="-B -w $PERFORCE_WEB_PORT -p $PERFORCE_PORT -v server=1"
-
-#
-# Uncomment this line to have the web server started automatically
-#
-#PERFORCE_WEB_START=yes
diff --git a/devel/p4web/files/perforce.sh.in b/devel/p4web/files/perforce.sh.in
deleted file mode 100644
index 2ebc5809fa48..000000000000
--- a/devel/p4web/files/perforce.sh.in
+++ /dev/null
@@ -1,61 +0,0 @@
-#!/bin/sh
-#
-# $FreeBSD$
-
-p4d=@PREFIX@/sbin/p4d
-p4ftpd=@PREFIX@/sbin/p4ftpd
-p4p=@PREFIX@/sbin/p4p
-p4web=@PREFIX@/sbin/p4web
-
-case $1 in
-start)
- [ -f @PREFIX@/etc/perforce.conf ] && . @PREFIX@/etc/perforce.conf
- if [ -x $p4d -a x$PERFORCE_START = xyes ]; then
- echo -n ' p4d'
- su -fm $PERFORCE_USER -c "$p4d -r $PERFORCE_ROOT $PERFORCE_OPTIONS"
- fi
- if [ -x $p4ftpd -a x$PERFORCE_FTPD_START = xyes ]; then
- echo -n ' p4ftpd'
- $p4ftpd $PERFORCE_FTPD_OPTIONS
- fi
- if [ -x $p4p -a x$PERFORCE_PROXY_START = xyes ]; then
- echo -n ' p4p'
- $p4p $PERFORCE_PROXY_OPTIONS
- fi
- if [ -x $p4web -a x$PERFORCE_WEB_START = xyes ]; then
- echo -n ' p4web'
- su -fm $PERFORCE_USER -c "$p4web $PERFORCE_WEB_OPTIONS &" >/dev/null 2>&1
- fi
-
- ;;
-stop)
- [ -f @PREFIX@/etc/perforce.conf ] && . @PREFIX@/etc/perforce.conf
- if [ -x $p4ftpd ]; then
- killall -u 0 p4ftpd >/dev/null 2>&1 && echo -n ' p4ftpd'
- fi
- if [ -x $p4d ]; then
- killall -u $PERFORCE_USER p4d >/dev/null 2>&1 && echo -n ' p4d'
- fi
- if [ -x $p4p ]; then
- killall -u 0 p4p > /dev/null 2>&1 && echo -n ' p4p'
- fi
- if [ -x $p4web ]; then
- killall -u $PERFORCE_USER p4web > /dev/null 2>&1 && echo -n ' p4web'
- fi
- ;;
-restart)
- $0 stop
- sleep 1
- $0 start
- ;;
-checkpoint)
- [ -f @PREFIX@/etc/perforce.conf ] && . @PREFIX@/etc/perforce.conf
- if [ -x $p4d -a x$PERFORCE_START = xyes ]; then
- su -fm $PERFORCE_USER -c "$p4d -r $PERFORCE_ROOT -jc"
- fi
- ;;
-*)
- echo "usage: $0 {start|stop|restart|checkpoint}"
- exit 64
- ;;
-esac
diff --git a/devel/p4web/pkg-descr b/devel/p4web/pkg-descr
deleted file mode 100644
index e6d35851b44b..000000000000
--- a/devel/p4web/pkg-descr
+++ /dev/null
@@ -1,4 +0,0 @@
-Perforce is a commercial revision control system that can be used
-gratis for developing free software. (see the WWW page for details).
-
-WWW: http://www.perforce.com/
diff --git a/devel/p4web/pkg-install b/devel/p4web/pkg-install
deleted file mode 100644
index 88b4d17472f4..000000000000
--- a/devel/p4web/pkg-install
+++ /dev/null
@@ -1,51 +0,0 @@
-#! /bin/sh
-#
-# $FreeBSD$
-
-PATH=/bin:/usr/sbin
-
-PERFORCE_USER=${PERFORCE_USER:-p4admin}
-PERFORCE_UID=${PERFORCE_UID:-94}
-PERFORCE_GROUP=${PERFORCE_GROUP:-p4admin}
-PERFORCE_GID=${PERFORCE_GID:-94}
-PERFORCE_HOME=${PERFORCE_HOME:-$PKG_PREFIX/perforce}
-PERFORCE_LOGDIR=${PERFORCE_LOGDIR:-$PERFORCE_HOME/log}
-PERFORCE_ROOT=${PERFORCE_ROOT:-$PERFORCE_HOME/root}
-
-case $2 in
-PRE-INSTALL)
- USER=${PERFORCE_USER}
- GROUP=${PERFORCE_GROUP}
- UID=${PERFORCE_UID}
- GID=${PERFORCE_GID}
-
- if pw group show "${GROUP}" 2>/dev/null; then
- echo "You already have a group \"${GROUP}\", so I will use it."
- else
- if pw groupadd ${GROUP} -g ${GID}; then
- echo "Added group \"${GROUP}\"."
- else
- echo "Adding group \"${GROUP}\" failed..."
- exit 1
- fi
- fi
-
- if pw user show "${USER}" 2>/dev/null; then
- echo "You already have a user \"${USER}\", so I will use it."
- else
- if pw useradd ${USER} -u ${UID} -g ${GROUP} -h - \
- -d ${PERFORCE_HOME} -c "Perforce admin" -s /sbin/nologin
- then
- echo "Added user \"${USER}\"."
- else
- echo "Adding user \"${USER}\" failed..."
- exit 1
- fi
- fi
-
- if [ ! -d $PERFORCE_HOME ] ; then
- mkdir -p $PERFORCE_HOME $PERFORCE_LOGS $PERFORCE_ROOT
- chown -R $USER:$GROUP $PERFORCE_HOME
- fi
- ;;
-esac
diff --git a/devel/p4web/pkg-plist b/devel/p4web/pkg-plist
deleted file mode 100644
index 31e0893152cc..000000000000
--- a/devel/p4web/pkg-plist
+++ /dev/null
@@ -1,4 +0,0 @@
-@unexec if cmp -s %D/etc/perforce.conf %D/etc/perforce.conf.default; then rm -f %D/etc/perforce.conf; fi
-etc/perforce.conf.default
-@exec [ ! -f %B/perforce.conf ] && cp -p %B/%f %B/perforce.conf || true
-etc/rc.d/perforce.sh