aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Alien-SDL/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/p5-Alien-SDL/Makefile')
-rw-r--r--devel/p5-Alien-SDL/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/devel/p5-Alien-SDL/Makefile b/devel/p5-Alien-SDL/Makefile
new file mode 100644
index 000000000000..9ee3b5803d33
--- /dev/null
+++ b/devel/p5-Alien-SDL/Makefile
@@ -0,0 +1,25 @@
+# $FreeBSD$
+
+PORTNAME= Alien-SDL
+PORTVERSION= 1.440
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= makc@FreeBSD.org
+COMMENT= Detect and get configuration setting for SDL
+
+LICENSE= GPLv2
+
+BUILD_DEPENDS:= ${RUN_DEPENDS} \
+ p5-Text-Patch>=1.4:${PORTSDIR}/textproc/p5-Text-Patch
+RUN_DEPENDS= p5-File-Which>=0:${PORTSDIR}/sysutils/p5-File-Which \
+ p5-File-ShareDir>=0:${PORTSDIR}/devel/p5-File-ShareDir \
+ p5-Capture-Tiny>=0:${PORTSDIR}/devel/p5-Capture-Tiny
+
+USES= perl5
+USE_PERL5= modbuild
+USE_SDL= gfx image mixer pango sdl ttf
+CONFIGURE_ARGS= --with-sdl-config=${SDL_CONFIG}
+
+.include <bsd.port.mk>