aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Class-MakeMethods
diff options
context:
space:
mode:
Diffstat (limited to 'devel/p5-Class-MakeMethods')
-rw-r--r--devel/p5-Class-MakeMethods/Makefile22
-rw-r--r--devel/p5-Class-MakeMethods/distinfo4
-rw-r--r--devel/p5-Class-MakeMethods/pkg-plist16
3 files changed, 34 insertions, 8 deletions
diff --git a/devel/p5-Class-MakeMethods/Makefile b/devel/p5-Class-MakeMethods/Makefile
index 770cff4898d8..6354cf8cd711 100644
--- a/devel/p5-Class-MakeMethods/Makefile
+++ b/devel/p5-Class-MakeMethods/Makefile
@@ -6,11 +6,12 @@
#
PORTNAME= Class-MakeMethods
-PORTVERSION= 1.006
+PORTVERSION= 1.010
CATEGORIES= devel perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= Class
PKGNAMEPREFIX= p5-
+DISTNAME= ${PORTNAME}-${PORTVERSION:C/.$//}
MAINTAINER= ports@FreeBSD.org
COMMENT= Generate common types of methods
@@ -42,6 +43,10 @@ MAN3= Class::MakeMethods.3 \
Class::MakeMethods::Emulator::MethodMaker.3 \
Class::MakeMethods::Emulator::Singleton.3 \
Class::MakeMethods::Emulator::Struct.3 \
+ Class::MakeMethods::Emulator::accessors.3 \
+ Class::MakeMethods::Emulator::mcoder.3 \
+ Class::MakeMethods::Evaled.3 \
+ Class::MakeMethods::Evaled::Hash.3 \
Class::MakeMethods::Standard.3 \
Class::MakeMethods::Standard::Array.3 \
Class::MakeMethods::Standard::Global.3 \
@@ -49,21 +54,32 @@ MAN3= Class::MakeMethods.3 \
Class::MakeMethods::Standard::Inheritable.3 \
Class::MakeMethods::Standard::Universal.3 \
Class::MakeMethods::Template.3 \
+ Class::MakeMethods::Template::Array.3 \
Class::MakeMethods::Template::Class.3 \
Class::MakeMethods::Template::ClassInherit.3 \
+ Class::MakeMethods::Template::ClassName.3 \
Class::MakeMethods::Template::ClassVar.3 \
Class::MakeMethods::Template::Flyweight.3 \
Class::MakeMethods::Template::Generic.3 \
+ Class::MakeMethods::Template::Global.3 \
Class::MakeMethods::Template::Hash.3 \
+ Class::MakeMethods::Template::InsideOut.3 \
+ Class::MakeMethods::Template::Inheritable.3 \
Class::MakeMethods::Template::PackageVar.3 \
Class::MakeMethods::Template::Ref.3 \
+ Class::MakeMethods::Template::Scalar.3 \
Class::MakeMethods::Template::Static.3 \
Class::MakeMethods::Template::Struct.3 \
Class::MakeMethods::Template::StructBuiltin.3 \
- Class::MakeMethods::Template::TextBuilder.3 \
Class::MakeMethods::Template::Universal.3 \
Class::MakeMethods::Utility::ArraySplicer.3 \
+ Class::MakeMethods::Utility::DiskCache.3 \
Class::MakeMethods::Utility::Inheritable.3 \
- Class::MakeMethods::Utility::Ref.3
+ Class::MakeMethods::Utility::Ref.3 \
+ Class::MakeMethods::Utility::TextBuilder.3
+
+post-extract:
+ @${RM} ${WRKSRC}/benchmark.pl
+ @${PERL} -pi -e '$$_="" if m|benchmark.pl|' ${WRKSRC}/MANIFEST
.include <bsd.port.mk>
diff --git a/devel/p5-Class-MakeMethods/distinfo b/devel/p5-Class-MakeMethods/distinfo
index 66d884d0c014..965ddc3ee6bb 100644
--- a/devel/p5-Class-MakeMethods/distinfo
+++ b/devel/p5-Class-MakeMethods/distinfo
@@ -1,2 +1,2 @@
-MD5 (Class-MakeMethods-1.006.tar.gz) = bb665e41f9834f342ecd123e9b7292c6
-SIZE (Class-MakeMethods-1.006.tar.gz) = 164666
+MD5 (Class-MakeMethods-1.01.tar.gz) = 838c98dcf1b1fff4c5d8cffaec32ebbb
+SIZE (Class-MakeMethods-1.01.tar.gz) = 162174
diff --git a/devel/p5-Class-MakeMethods/pkg-plist b/devel/p5-Class-MakeMethods/pkg-plist
index 7056fd6f3916..654d3bef300c 100644
--- a/devel/p5-Class-MakeMethods/pkg-plist
+++ b/devel/p5-Class-MakeMethods/pkg-plist
@@ -1,4 +1,5 @@
%%SITE_PERL%%/%%PERL_ARCH%%/auto/Class/MakeMethods/.packlist
+
%%SITE_PERL%%/Class/MakeMethods.pm
%%SITE_PERL%%/Class/MakeMethods/Attribute.pm
%%SITE_PERL%%/Class/MakeMethods/Autoload.pm
@@ -24,6 +25,10 @@
%%SITE_PERL%%/Class/MakeMethods/Emulator/MethodMaker.pm
%%SITE_PERL%%/Class/MakeMethods/Emulator/Singleton.pm
%%SITE_PERL%%/Class/MakeMethods/Emulator/Struct.pm
+%%SITE_PERL%%/Class/MakeMethods/Emulator/accessors.pm
+%%SITE_PERL%%/Class/MakeMethods/Emulator/mcoder.pm
+%%SITE_PERL%%/Class/MakeMethods/Evaled.pm
+%%SITE_PERL%%/Class/MakeMethods/Evaled/Hash.pm
%%SITE_PERL%%/Class/MakeMethods/Standard.pm
%%SITE_PERL%%/Class/MakeMethods/Standard/Array.pm
%%SITE_PERL%%/Class/MakeMethods/Standard/Global.pm
@@ -31,30 +36,35 @@
%%SITE_PERL%%/Class/MakeMethods/Standard/Inheritable.pm
%%SITE_PERL%%/Class/MakeMethods/Standard/Universal.pm
%%SITE_PERL%%/Class/MakeMethods/Template.pm
+%%SITE_PERL%%/Class/MakeMethods/Template/Array.pm
%%SITE_PERL%%/Class/MakeMethods/Template/Class.pm
%%SITE_PERL%%/Class/MakeMethods/Template/ClassInherit.pm
%%SITE_PERL%%/Class/MakeMethods/Template/ClassName.pm
%%SITE_PERL%%/Class/MakeMethods/Template/ClassVar.pm
-%%SITE_PERL%%/Class/MakeMethods/Template/DiskCache.pm
%%SITE_PERL%%/Class/MakeMethods/Template/Flyweight.pm
%%SITE_PERL%%/Class/MakeMethods/Template/Generic.pm
+%%SITE_PERL%%/Class/MakeMethods/Template/Global.pm
%%SITE_PERL%%/Class/MakeMethods/Template/Hash.pm
+%%SITE_PERL%%/Class/MakeMethods/Template/Inheritable.pm
+%%SITE_PERL%%/Class/MakeMethods/Template/InsideOut.pm
%%SITE_PERL%%/Class/MakeMethods/Template/PackageVar.pm
-%%SITE_PERL%%/Class/MakeMethods/Template/PseudoHash.pm
%%SITE_PERL%%/Class/MakeMethods/Template/Ref.pm
%%SITE_PERL%%/Class/MakeMethods/Template/Scalar.pm
%%SITE_PERL%%/Class/MakeMethods/Template/Static.pm
%%SITE_PERL%%/Class/MakeMethods/Template/Struct.pm
%%SITE_PERL%%/Class/MakeMethods/Template/StructBuiltin.pm
-%%SITE_PERL%%/Class/MakeMethods/Template/TextBuilder.pm
%%SITE_PERL%%/Class/MakeMethods/Template/Universal.pm
%%SITE_PERL%%/Class/MakeMethods/Utility/ArraySplicer.pm
+%%SITE_PERL%%/Class/MakeMethods/Utility/DiskCache.pm
%%SITE_PERL%%/Class/MakeMethods/Utility/Inheritable.pm
%%SITE_PERL%%/Class/MakeMethods/Utility/Ref.pm
+%%SITE_PERL%%/Class/MakeMethods/Utility/TextBuilder.pm
+
@unexec rmdir %D/%%SITE_PERL%%/Class/MakeMethods/Basic 2>/dev/null || true
@unexec rmdir %D/%%SITE_PERL%%/Class/MakeMethods/Composite 2>/dev/null || true
@unexec rmdir %D/%%SITE_PERL%%/Class/MakeMethods/Docs 2>/dev/null || true
@unexec rmdir %D/%%SITE_PERL%%/Class/MakeMethods/Emulator 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Class/MakeMethods/Evaled 2>/dev/null || true
@unexec rmdir %D/%%SITE_PERL%%/Class/MakeMethods/Standard 2>/dev/null || true
@unexec rmdir %D/%%SITE_PERL%%/Class/MakeMethods/Template 2>/dev/null || true
@unexec rmdir %D/%%SITE_PERL%%/Class/MakeMethods/Utility 2>/dev/null || true