aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Coro/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/p5-Coro/Makefile')
-rw-r--r--devel/p5-Coro/Makefile10
1 files changed, 2 insertions, 8 deletions
diff --git a/devel/p5-Coro/Makefile b/devel/p5-Coro/Makefile
index 047042ac5cb9..a9a314ed1c17 100644
--- a/devel/p5-Coro/Makefile
+++ b/devel/p5-Coro/Makefile
@@ -22,7 +22,7 @@ RUN_DEPENDS= p5-Event>=0.89:${PORTSDIR}/devel/p5-Event \
${SITE_PERL}/${PERL_ARCH}/IO/AIO.pm:${PORTSDIR}/devel/p5-IO-AIO
BUILD_DEPENDS= ${RUN_DEPENDS}
-PERL_CONFIGURE= yes
+PERL_CONFIGURE= 5.8.0+
MAN3= Coro.3 Coro::AIO.3 Coro::Channel.3 Coro::Handle.3 \
Coro::LWP.3 Coro::MakeMaker.3 Coro::RWLock.3 Coro::Select.3 \
@@ -30,12 +30,6 @@ MAN3= Coro.3 Coro::AIO.3 Coro::Channel.3 Coro::Handle.3 \
Coro::Socket.3 Coro::Specific.3 Coro::State.3 Coro::Storable.3 \
Coro::Timer.3 Coro::Util.3 Coro::Event.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500800
-IGNORE= requires perl 5.8.0 or later. Install lang/perl5.8 and try again
-.endif
-
post-install:
${MKDIR} ${EXAMPLESDIR}
${INSTALL_SCRIPT} ${WRKSRC}/eg/* ${EXAMPLESDIR}
@@ -44,4 +38,4 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/doc/cede-vs-schedule ${DOCSDIR}
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>