aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Data-Throttler/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/p5-Data-Throttler/Makefile')
-rw-r--r--devel/p5-Data-Throttler/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/devel/p5-Data-Throttler/Makefile b/devel/p5-Data-Throttler/Makefile
new file mode 100644
index 000000000000..163bacb189a2
--- /dev/null
+++ b/devel/p5-Data-Throttler/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: p5-Data-Throttler
+# Date created: 2008-01-30
+# Whom: Masahiro Teramoto <markun@onohara.to>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Data-Throttler
+PORTVERSION= 0.01
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= markun@onohara.to
+COMMENT= Limit data throughput
+
+BUILD_DEPENDS= p5-DBM-Deep>=1.0001:${PORTSDIR}/databases/p5-DBM-Deep \
+ p5-Log-Log4perl>=1:${PORTSDIR}/devel/p5-Log-Log4perl \
+ p5-Set-IntSpan>=0:${PORTSDIR}/math/p5-Set-IntSpan \
+ p5-Text-ASCIITable>=0:${PORTSDIR}/textproc/p5-Text-ASCIITable
+RUN_DEPENDS= p5-DBM-Deep>=1.0001:${PORTSDIR}/databases/p5-DBM-Deep \
+ p5-Log-Log4perl>=1:${PORTSDIR}/devel/p5-Log-Log4perl \
+ p5-Set-IntSpan>=0:${PORTSDIR}/math/p5-Set-IntSpan \
+ p5-Text-ASCIITable>=0:${PORTSDIR}/textproc/p5-Text-ASCIITable
+
+PERL_CONFIGURE= yes
+
+MAN3= Data::Throttler.3
+
+.include <bsd.port.mk>