aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Date-Piece
diff options
context:
space:
mode:
Diffstat (limited to 'devel/p5-Date-Piece')
-rw-r--r--devel/p5-Date-Piece/Makefile24
-rw-r--r--devel/p5-Date-Piece/distinfo2
-rw-r--r--devel/p5-Date-Piece/pkg-descr8
-rw-r--r--devel/p5-Date-Piece/pkg-plist3
4 files changed, 37 insertions, 0 deletions
diff --git a/devel/p5-Date-Piece/Makefile b/devel/p5-Date-Piece/Makefile
new file mode 100644
index 000000000000..7c55cab93733
--- /dev/null
+++ b/devel/p5-Date-Piece/Makefile
@@ -0,0 +1,24 @@
+# Created by: Erwin Lansing <erwin@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= Date-Piece
+PORTVERSION= 0.0.3
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= CPAN:EWILHELM
+PKGNAMEPREFIX= p5-
+DISTNAME= Date-Piece-v0.0.3
+
+MAINTAINER= erwin@FreeBSD.org
+COMMENT= Perl5 module containing date manipulation routines
+
+BUILD_DEPENDS= p5-Date-Simple>=3.03:${PORTSDIR}/devel/p5-Date-Simple
+RUN_DEPENDS= p5-Date-Simple>=3.03:${PORTSDIR}/devel/p5-Date-Simple
+#TEST_DEPENDS= p5-Test-Inter>=0:${PORTSDIR}/devel/p5-Test-Inter
+
+PERL_MODBUILD= YES
+
+MAN1= day.1
+MAN3= Date::Piece.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Date-Piece/distinfo b/devel/p5-Date-Piece/distinfo
new file mode 100644
index 000000000000..d8f5c850df16
--- /dev/null
+++ b/devel/p5-Date-Piece/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Date-Piece-v0.0.3.tar.gz) = f6ac3a08d6c3b3a9271e64ba3d99a4f8f531b8508066761d91fd1703edd4f39b
+SIZE (Date-Piece-v0.0.3.tar.gz) = 13539
diff --git a/devel/p5-Date-Piece/pkg-descr b/devel/p5-Date-Piece/pkg-descr
new file mode 100644
index 000000000000..f2f10540e1b0
--- /dev/null
+++ b/devel/p5-Date-Piece/pkg-descr
@@ -0,0 +1,8 @@
+This module allows you to do nominal math on dates. That is, rather
+than worrying about time zones and DST while adding increments of
+24*60**2 seconds to a date&time object, you simply discard the time
+component and do math directly on the date. If you need a time-of-day
+on the calculated date, the at() method returns a Time::Piece object,
+thus allowing you to be specific about the endpoints of a nominal interval.
+
+WWW: http://search.cpan.org/dist/Date-Piece/
diff --git a/devel/p5-Date-Piece/pkg-plist b/devel/p5-Date-Piece/pkg-plist
new file mode 100644
index 000000000000..266100a7ee64
--- /dev/null
+++ b/devel/p5-Date-Piece/pkg-plist
@@ -0,0 +1,3 @@
+bin/day
+%%SITE_PERL%%/Date/Piece.pm
+@dirrmtry %%SITE_PERL%%/Date