aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-DateTime-Format-DBI
diff options
context:
space:
mode:
Diffstat (limited to 'devel/p5-DateTime-Format-DBI')
-rw-r--r--devel/p5-DateTime-Format-DBI/Makefile28
-rw-r--r--devel/p5-DateTime-Format-DBI/distinfo1
-rw-r--r--devel/p5-DateTime-Format-DBI/pkg-descr6
-rw-r--r--devel/p5-DateTime-Format-DBI/pkg-plist7
4 files changed, 42 insertions, 0 deletions
diff --git a/devel/p5-DateTime-Format-DBI/Makefile b/devel/p5-DateTime-Format-DBI/Makefile
new file mode 100644
index 000000000000..b734a3638a00
--- /dev/null
+++ b/devel/p5-DateTime-Format-DBI/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: p5-DateTime-Format-DBI
+# Date created: 2 july 2003
+# Whom: Mathieu Arnold <m@absolight.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= DateTime-Format-DBI
+PORTVERSION= 0.02
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= DateTime
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= m@absolight.net
+COMMENT= Find a parser class for a database connection
+
+RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/DateTime.pm:${PORTSDIR}/devel/p5-DateTime
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= DateTime::Format::DBI.3
+
+post-patch:
+ @${PERL} -pi -e 's/^our (\S+)/use vars qw($$1); $$1/' ${WRKSRC}/lib/DateTime/Format/DBI.pm
+
+.include <bsd.port.mk>
diff --git a/devel/p5-DateTime-Format-DBI/distinfo b/devel/p5-DateTime-Format-DBI/distinfo
new file mode 100644
index 000000000000..f6b465ec078f
--- /dev/null
+++ b/devel/p5-DateTime-Format-DBI/distinfo
@@ -0,0 +1 @@
+MD5 (DateTime-Format-DBI-0.02.tar.gz) = c3a1d74bd4dde69ae1d0329bc79ef7a3
diff --git a/devel/p5-DateTime-Format-DBI/pkg-descr b/devel/p5-DateTime-Format-DBI/pkg-descr
new file mode 100644
index 000000000000..5417109a6fa2
--- /dev/null
+++ b/devel/p5-DateTime-Format-DBI/pkg-descr
@@ -0,0 +1,6 @@
+This module finds a DateTime::Format::* class that is suitable for the use with
+a given DBI connection (and DBD::* driver).
+
+It currently supports the following drivers: MySQL, PostgreSQL (Pg).
+
+WWW: http://datetime.perl.org/
diff --git a/devel/p5-DateTime-Format-DBI/pkg-plist b/devel/p5-DateTime-Format-DBI/pkg-plist
new file mode 100644
index 000000000000..cbbaabeea31c
--- /dev/null
+++ b/devel/p5-DateTime-Format-DBI/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/DateTime/Format/DBI.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/DateTime/Format/DBI/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/DateTime/Format/DBI
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/DateTime/Format 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/DateTime 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/DateTime/Format 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/DateTime 2>/dev/null || true