aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-DateTime-Locale/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/p5-DateTime-Locale/Makefile')
-rw-r--r--devel/p5-DateTime-Locale/Makefile12
1 files changed, 11 insertions, 1 deletions
diff --git a/devel/p5-DateTime-Locale/Makefile b/devel/p5-DateTime-Locale/Makefile
index a50ad216dce4..aff4d4166cf0 100644
--- a/devel/p5-DateTime-Locale/Makefile
+++ b/devel/p5-DateTime-Locale/Makefile
@@ -6,11 +6,12 @@
#
PORTNAME= DateTime-Locale
-PORTVERSION= 0.09
+PORTVERSION= 0.20
CATEGORIES= devel perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= DateTime
PKGNAMEPREFIX= p5-
+DISTNAME= ${PORTNAME}-${PORTVERSION:S/0$//}
MAINTAINER= mat@FreeBSD.org
COMMENT= Localization support for DateTime
@@ -23,4 +24,13 @@ PERL_MODBUILD= yes
MAN3= DateTime::Locale.3 DateTime::Locale::Alias::ISO639_2.3 \
DateTime::Locale::Base.3 DateTime::LocaleCatalog.3
+.if !defined(NOPORTDOCS)
+PORTDOCS= Changes
+
+post-install:
+ @${MKDIR} ${DOCSDIR}
+ @${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
+ @${ECHO_MSG} "===> Documentation installed in ${DOCSDIR}."
+.endif
+
.include <bsd.port.mk>