aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-DateTime/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/p5-DateTime/Makefile')
-rw-r--r--devel/p5-DateTime/Makefile11
1 files changed, 7 insertions, 4 deletions
diff --git a/devel/p5-DateTime/Makefile b/devel/p5-DateTime/Makefile
index a3025447ada8..37a7818c8c2b 100644
--- a/devel/p5-DateTime/Makefile
+++ b/devel/p5-DateTime/Makefile
@@ -6,25 +6,28 @@
#
PORTNAME= DateTime
-PORTVERSION= 0.13
+PORTVERSION= 0.15
CATEGORIES= devel perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= DateTime
PKGNAMEPREFIX= p5-
+DISTNAME= ${PORTNAME}-${PORTVERSION}02
MAINTAINER= m@absolight.net
COMMENT= A date and time object
-BUILD_DEPENDS= ${SITE_PERL}/Class/Factory/Util.pm:${PORTSDIR}/devel/p5-Class-Factory-Util \
+RUN_DEPENDS= ${SITE_PERL}/Class/Factory/Util.pm:${PORTSDIR}/devel/p5-Class-Factory-Util \
${SITE_PERL}/${PERL_ARCH}/Params/Validate.pm:${PORTSDIR}/devel/p5-Params-Validate \
${SITE_PERL}/DateTime/LeapSecond.pm:${PORTSDIR}/devel/p5-DateTime-LeapSecond \
${SITE_PERL}/DateTime/TimeZone.pm:${PORTSDIR}/devel/p5-DateTime-TimeZone \
+ ${SITE_PERL}/DateTime/Locale.pm:${PORTSDIR}/devel/p5-DateTime-Locale \
${SITE_PERL}/Time/Local.pm:${PORTSDIR}/devel/p5-Time-Local
-RUN_DEPENDS= ${BUILD_DEPENDS}
+BUILD_DEPENDS= ${RUN_DEPENDS} \
+ ${SITE_PERL}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple
PERL_CONFIGURE= yes
MAN3= DateTime.3 DateTime::Duration.3 \
- DateTime::Infinite.3 DateTime::Language.3
+ DateTime::Infinite.3
.include <bsd.port.mk>