aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-File-CreationTime/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/p5-File-CreationTime/Makefile')
-rw-r--r--devel/p5-File-CreationTime/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/devel/p5-File-CreationTime/Makefile b/devel/p5-File-CreationTime/Makefile
new file mode 100644
index 000000000000..68a89be324cf
--- /dev/null
+++ b/devel/p5-File-CreationTime/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: devel/p5-File-CreationTime
+# Date created: 04 April 2007
+# Whom: Anton Berezin <tobez@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= File-CreationTime
+PORTVERSION= 2.03
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= File
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= tobez@FreeBSD.org
+COMMENT= Keeps track of file creation times
+
+BUILD_DEPENDS= ${SITE_PERL}/File/Attributes.pm:${PORTSDIR}/devel/p5-File-Attributes
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= File::CreationTime.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+IGNORE= has a dependency that wants perl5.8
+.endif
+
+.include <bsd.port.post.mk>